Opened 7 years ago

Closed 7 years ago

#15762 closed defect (duplicate)

TypeError: this.parseDeferred is undefined

Reported by: psiberia Owned by: psiberia
Priority: high Milestone: 1.8
Component: Dijit Version: 1.8.0rc1
Keywords: Cc:
Blocked By: Blocking:

Description

I have the following error after upgrading from Dojo 1.8.0b1 to 1.8.0rc1

Firebug (Firefox) TypeError?: this.parseDeferred is undefined http://localhost:8080/lib/dojo/dojox/html/_base.js?1343227888966 Line 165

Chrome Uncaught TypeError?: Cannot call method 'then' of undefined

The code that reproduces the error is attached. See lines 65-70.

Attachments (2)

issue-15762.html (1.9 KB) - added by psiberia 7 years ago.
updated code sample to reproduce error
issue-15762.2.html (2.0 KB) - added by psiberia 7 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 7 years ago by Kitson Kelly

Milestone: tbd1.8
Owner: changed from bill to psiberia
Priority: undecidedhigh
Status: newpending

There is no dojoConfig apparent from the test file. A couple of issues with this:

  • dojo/dojo.js defaults to async: false. You should not be using dojo/domReady! with the legacy loader. It will break things.
  • If you are using async: true, you are using Dijit's which are dependent upon dojo/uacss and dojo/hccss loading before the widgets are instantiated, but you are not using dojo/ready to accomplish this and instead on dojo/domReady!. You need to wrap your code in dojo/ready.

Could you address the issues above and confirm if the issue still persists or not?

comment:2 Changed 7 years ago by psiberia

Status: pendingnew

Apologies I removed the unnecessary code and forgot I had externalized my dojoConfig. I have updated the code to include the dojoConfig and the error still occurs, which I expected as I was getting it prior to stripping down the code.

Changed 7 years ago by psiberia

Attachment: issue-15762.html added

updated code sample to reproduce error

comment:3 Changed 7 years ago by Kitson Kelly

Status: newpending

The second point still stands... You should not use the dojo/domReady! with widgets... Please see: http://livedocs.dojotoolkit.org/dojo/domReady#dijit-widgets

Also if you using the parser and async and parseOnLoad: true, you should require in dojo/parser. Please see: http://livedocs.dojotoolkit.org/dojo/parser#running-the-parser

comment:4 Changed 7 years ago by Adam Peller

May be a dup of #15731

Changed 7 years ago by psiberia

Attachment: issue-15762.2.html added

comment:5 Changed 7 years ago by psiberia

Status: pendingnew

Attachment (issue-15762.2.html) added by ticket reporter.

comment:6 Changed 7 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #15731.
Like Adam said, it's already fixed.

Note: See TracTickets for help on using tickets.