Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15760 closed defect (fixed)

[cla] [patch] dojo/rpc/RpcService default timeout too short (3 seconds)

Reported by: kbenjamin Owned by: Dustin Machi
Priority: undecided Milestone: 1.9
Component: RPC Version: 1.8.0rc1
Keywords: Cc:
Blocked By: Blocking:

Description

A default xhr timeout is set on all RpcService? requests of only 3 seconds. This would appear to be a typo and probably was supposed to default to 30 seconds.

62: this.timeout = args.timeout || 3000;

Probably should be:

62: this.timeout = args.timeout || 30000;

This also impacts dojo/rpc/JsonService and dojo/rpc/JsonpService which extend RpcService?.

The obvious and easy work-around is to specify timeout: 30000 when creating a new RPC service but since the default may work in development with a local server and then fail in production, I feel this should be fixed.

Change History (3)

comment:1 Changed 7 years ago by freddefisk

This is (almost) a duplicate of #13987 where it's proposed that the default timeout is disabled.

comment:2 Changed 7 years ago by dylan

Resolution: fixed
Status: newclosed

In [30743]:

fixes #13987 #15760, change default rpc timeout to not timeout at all, rather than after just 3s

comment:3 Changed 7 years ago by dylan

Milestone: tbd1.9
Note: See TracTickets for help on using tickets.