Opened 7 years ago

Closed 7 years ago

#15746 closed defect (fixed)

Nightly build is broken: css import error messages

Reported by: Adam Peller Owned by: Rawld Gill
Priority: blocker Milestone: 1.8
Component: Dojox Version: 1.7.3
Keywords: Cc: Colin Snover, rchady
Blocked By: Blocking:

Description

Grabbing SVN HEAD...
processing profile resource /srv/www/vhosts.d/archive.dojotoolkit.org/dojo-2012-07-24/checkout/util/buildscripts/profiles/demos-all.profile.js
info(107) Package Version: package: dojox; version: 1.8.0dev
processing profile resource /srv/www/vhosts.d/archive.dojotoolkit.org/dojo-2012-07-24/checkout/dojox/dojox.profile.js
info(107) Package Version: package: dijit; version: 1.8.0dev
processing profile resource /srv/www/vhosts.d/archive.dojotoolkit.org/dojo-2012-07-24/checkout/dijit/dijit.profile.js
info(107) Package Version: package: dojo; version: 1.8.0dev
processing profile resource /srv/www/vhosts.d/archive.dojotoolkit.org/dojo-2012-07-24/checkout/dojo/dojo.profile.js
info(107) Package Version: package: demos; version: 1.8.0dev
processing profile resource /srv/www/vhosts.d/archive.dojotoolkit.org/dojo-2012-07-24/checkout/demos/demos.profile.js
info(107) Package Version: package: doh; version: 1.8.0dev
processing profile resource /srv/www/vhosts.d/archive.dojotoolkit.org/dojo-2012-07-24/checkout/util/doh/doh.profile.js
warn(217) the clean action has been removed; use rm (*nix) or rmdir (Windows) 
discovering resources...
starting reading resources...
starting processing raw resource content...
starting tokenizing resource...
starting processing resource tokens...
starting parsing resource...
starting processing resource AST...
warn(216) dojo/has plugin resource could not be resolved during build-time. plugin resource id: touch?dojox/gesture/tap; reference module id: dojox/treemap/DrillDownUp
warn(224) A plugin dependency was encountered but there was no build-time plugin resolver. module: dojox/mobile/TimePicker; plugin: dojox/mobile/_PickerChooser
warn(224) A plugin dependency was encountered but there was no build-time plugin resolver. module: dojox/mobile/DatePicker; plugin: dojox/mobile/_PickerChooser
warn(216) dojo/has plugin resource could not be resolved during build-time. plugin resource id: dojo-parser?:dojo/_base/window; reference module id: dojox/mvc/parserExtension
warn(216) dojo/has plugin resource could not be resolved during build-time. plugin resource id: dojo-mobile-parser?:dojo/parser; reference module id: dojox/mvc/parserExtension
warn(216) dojo/has plugin resource could not be resolved during build-time. plugin resource id: dojo-parser?:dojox/mobile/parser; reference module id: dojox/mvc/parserExtension
warn(224) A plugin dependency was encountered but there was no build-time plugin resolver. module: dojo/request/node; plugin: dojo/node
warn(224) A plugin dependency was encountered but there was no build-time plugin resolver. module: dojo/request/node; plugin: dojo/node
warn(224) A plugin dependency was encountered but there was no build-time plugin resolver. module: dojo/request/node; plugin: dojo/node
warn(224) A plugin dependency was encountered but there was no build-time plugin resolver. module: dojo/request/node; plugin: dojo/node
warn(216) dojo/has plugin resource could not be resolved during build-time. plugin resource id: dojo-firebug?./_firebug/firebug; reference module id: dojo/main
warn(224) A plugin dependency was encountered but there was no build-time plugin resolver. module: dojo/request; plugin: dojo/request/default
warn(216) dojo/has plugin resource could not be resolved during build-time. plugin resource id: dom-addeventlistener?:./aspect; reference module id: dojo/on
warn(216) dojo/has plugin resource could not be resolved during build-time. plugin resource id: host-browser?dom-addeventlistener?:../on:; reference module id: dojo/request/watch
warn(224) A plugin dependency was encountered but there was no build-time plugin resolver. module: dojo/request/registry; plugin: dojo/request/default
warn(216) dojo/has plugin resource could not be resolved during build-time. plugin resource id: touch?dojox/charting/action2d/TouchZoomAndPan:dojox/charting/action2d/MouseZoomAndPan; reference module id: demos/mobileCharting/src
warn(216) dojo/has plugin resource could not be resolved during build-time. plugin resource id: touch?dojox/charting/action2d/TouchIndicator:dojox/charting/action2d/MouseIndicator; reference module id: demos/mobileCharting/src
warn(202) AMD module specified and absolute module identifier that is not consistent with the configuration and filename module: demos/mobileMvc/src; specified: dojox/mvc/MobileDemoGenerateActions
error(311) Missing dependency. module: demos/mobileMvc/src; dependency: dojox/mvc/MobileDemoContactModel
error(311) Missing dependency. module: demos/mobileMvc/src; dependency: dojox/mvc/MobileDemoContactListModel
error(311) Missing dependency. module: demos/mobileMvc/src; dependency: dojox/mvc/MobileDemoContactController
error(311) Missing dependency. module: demos/mobileMvc/src; dependency: dojox/mvc/MobileDemoContactListController
error(311) Missing dependency. module: demos/mobileMvc/src; dependency: dojox/mvc/MobileDemoGenerateActions
starting executing global optimizations...
error(359) While optimizing a CSS file, an import directive was not expanded as instructed by the profile. CSS file: /srv/www/vhosts.d/archive.dojotoolkit.org/dojo-2012-07-24/checkout/dijit/themes/soria/soria.css; import directive: @import url("../dijit.css");
error(359) While optimizing a CSS file, an import directive was not expanded as instructed by the profile. CSS file: /srv/www/vhosts.d/archive.dojotoolkit.org/dojo-2012-07-24/checkout/dijit/themes/nihilo/nihilo.css; import directive: @import url("../dijit.css");
error(359) While optimizing a CSS file, an import directive was not expanded as instructed by the profile. CSS file: /srv/www/vhosts.d/archive.dojotoolkit.org/dojo-2012-07-24/checkout/dijit/themes/tundra/tundra.css; import directive: @import url("../dijit.css");
error(359) While optimizing a CSS file, an import directive was not expanded as instructed by the profile. CSS file: /srv/www/vhosts.d/archive.dojotoolkit.org/dojo-2012-07-24/checkout/dijit/themes/claro/claro.css; import directive: @import url("../dijit.css");
starting writing resources...
WARNING: Found a `debugger;` statement in code being compressed
starting cleaning up...
starting reporting...
Report written to /srv/www/vhosts.d/archive.dojotoolkit.org/dojo-2012-07-24/checkout/release/demosite/build-report.txt
Process finished normally.
	errors: 9
	warnings: 19
	build time: 598.431 seconds

BUILD FAILED, aborting...

Attachments (1)

mvc-mobileMvcDemo-15746.patch (15.8 KB) - added by Ed Chatelain 7 years ago.
This patch should fix the missing dependency errors for the mobileMvc demo. There are new files included in the patch to be added to svn.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 7 years ago by Adam Peller

Cc: Colin Snover added
Milestone: tbd1.8
Owner: changed from Adam Peller to cjolif
Priority: undecidedblocker
Status: newassigned

comment:2 Changed 7 years ago by Adam Peller

Cc: rchady added

comment:3 Changed 7 years ago by Adam Peller

Not sure if it's also blocking the build, but can you take a look at the CSS errors and debugger statement, too?

comment:4 Changed 7 years ago by Ed Chatelain

Owner: changed from cjolif to Ed Chatelain

comment:5 Changed 7 years ago by Ed Chatelain

I thought I had tested a build of this before it was committed, (maybe I ran the build in the wrong tree?) Anyway I was able to see the missing dependency errors, and the patch fixes those. I do not get the css errors shown.

Changed 7 years ago by Ed Chatelain

This patch should fix the missing dependency errors for the mobileMvc demo. There are new files included in the patch to be added to svn.

comment:6 Changed 7 years ago by Ed Chatelain

Cc: wildbill added

I will need someone to review and commit the patch, maybe peller? or wildbill?

comment:7 Changed 7 years ago by Ed Chatelain

Cc: bill added; wildbill removed

comment:8 Changed 7 years ago by Adam Peller

committed edchat's patch in r29373 Confirm that the CSS warnings no longer exist or do not break the build. If the latter, we can handle that under a separate ticket for 1.8.1

comment:9 Changed 7 years ago by Ed Chatelain

The "error(311) Missing dependency. module: demos/mobileMvc/src" errors are now fixed in the nightly build, but the "error(359) While optimizing a CSS file" errors are still occurring. I was told that this is the command being run for the nightly build:

./build.sh copyTests=true mini=false action=clean,release profile=demos-all cssOptimize=comments.keepLines cssImportIgnore=../dijit.css

I did see the css errors on Windows with that command, but the build still completed normally. If I remove the "cssImportIgnore=../dijit.css" I did not see the css errors.

comment:10 Changed 7 years ago by bill

Summary: Nightly build is broken: demos/mobileMvc/src dependencies missingNightly build is broken: css import errors in demos

comment:11 Changed 7 years ago by bill

Cc: bill removed
Owner: changed from Ed Chatelain to Rawld Gill

Fails due to cssImportIgnore, reproducible on:

./build.sh  mini=false action=clean,release profile=standard cssOptimize=comments.keepLines cssImportIgnore=../dijit.css

comment:12 Changed 7 years ago by bill

Summary: Nightly build is broken: css import errors in demosNightly build is broken: css import error messages

Caused/tracked by #15763.

comment:13 Changed 7 years ago by Rawld Gill

Resolution: fixed
Status: assignedclosed

fixed in [29400] at #15763

Note: See TracTickets for help on using tickets.