Opened 7 years ago

Closed 7 years ago

#15744 closed defect (worksforme)

Can not read style property of null

Reported by: daniel.payne Owned by: daniel.payne
Priority: undecided Milestone: tbd
Component: Charting Version: 1.8.0rc1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by Kitson Kelly)

in the javaScript console in chrome - there is an error stack - not sure if it is a bug; here is the test page

<!DOCTYPE html>

<html>

<head>

<meta charset="utf-8"/>

<title>Untitled</title>

    <!-- REMOVE FOR PRODUCTION -->

    <meta http-equiv="cache-control" content="no-cache">

    <meta http-equiv="pragma"        content="no-cache">







    <script>
      var dojoConfig = {    


        isDebug:     true, 

        parseOnLoad: false, 

        async:       true,  


        packages: [        

          {name:  "ertoc",   location: location.href.replace(/\/[^/]+$/, '') + "/scripts"} 

        ]


      };


    </script>


    <!--

    <script src="http://ajax.googleapis.com/ajax/libs/dojo/1.7.2/dojo/dojo.js" ></script>

  	-->



    <script src="./scripts/dojo 1.8.0/dojo/dojo.js" ></script>



    <script type="text/javascript">



      define("dojox.charting.themes.danTheme", ["dojox/charting/Theme", "dojox/charting/themes/common"], function (theme, themes) {



        themes.DanTheme = new dojox.charting.Theme({         

 		      chart: {

			      fill:	          "#C5C5DA"   

		      },         

          plotarea: { fill: "#C5C5DA" }

        });



        return themes.DanTheme;

      });



      require([



        "ertoc/app",



        "dojox/mobile",

        "dojox/mobile/parser",

        "dojox/mobile/deviceTheme",

        "dojox/mobile/compat",

        "dojox/mobile/TextArea",

        "dojox/mobile/ContentPane",

        "dojox/mobile/TextBox",

        "dojox/mobile/Button",

        "dojox/mobile/SimpleDialog",

        "dojox/mobile/TextArea",

        "dojox/mobile/ExpandingTextArea",



        "dojox.charting.themes.danTheme",



        //"dojox/charting/widget/Chart2D",

        //"dojox/charting/Chart",

        //"dojox/charting/widget/Chart",



        

        "dojox/charting/widget/Chart",

        "dojox/charting/axis2d/Default",

        "dojox/charting/plot2d/Areas",

        "dojox/charting/plot2d/Lines",

        "dojox/charting/plot2d/Columns",

 



        "dojo/domReady!"

      ], function (app) {

      

        app.initilize();

      });

    </script>

</head>



<body >    

<!-- ===================================================================================================================================================== -->



<div id="ViewReports"          data-dojo-type="dojox.mobile.View" style="height: 100%;"       >



  <h1 label="Reports" data-dojo-type="dojox.mobile.Heading" back="Menu" moveTo="ViewMenu">

  </h1>

  





   <div class="Round-Rect-Info" data-dojo-type="dojox.mobile.RoundRect" shadow="false" >



     <span>Utilization and Empty Running (%)</span>



		 <div dojoType="dojox.charting.widget.Chart" id="chartConsignments" style="width: 100%; height: 180px;" theme="dojox.charting.themes.DanTheme"> 

		 	

		 	<div class="axis" name="axisY" vertical="true" min="-30" max="30"  ></div>

		 	

        <div class="plot" name="plotEmptys"       type="Columns" gap="12" tension= "3"  markers="false" vAxis="axisY" ></div> 

        <div class="plot" name="plotUtilizations" type="Columns" gap="10" tension= "3"  markers="false" vAxis="axisY"  ></div> 

		 	

     

        <div class="series" name="dataEmptyRunning" plot="plotEmptys"      

          data="-21, -12, -21.3, -23.2, -6.3, -100, -12.3, -27.3">

        </div> 

     

        <div class="series" name="dataUtilization" plot="plotUtilizations"      

          data="26.8, 26.2, 27.4, 25.3, 26.4, 0.0, 26.5, 26.3">

        </div> 

		 </div>



   </div>

 

  <div class="Round-Rect-Info" data-dojo-type="dojox.mobile.RoundRect" shadow="false" >



     <span>Fuel Consumption (Mpg)</span>

			

     <div dojoType="dojox.charting.widget.Chart" id="chartConsumptions" style="width: 100%; height: 180px;" theme="dojox.charting.themes.DanTheme"> 

				

				<div class="axis" name="axisY" vertical="true" fixUpper="major" includeZero="true" ></div>

				

       <div class="plot" name="plotConsumptions" type="Lines" tension= "3"  markers="true" vAxis="axisY" ></div>

				

       <div class="series" name="seriesConsumptions" plot="plotConsumptions" data="1, 2, 0.5, 1.5, 1, 2.8, 0.4"></div>



			</div>



   </div>



</div>







<!-- ===================================================================================================================================================== -->

</body>



</html>

Attachments (1)

test_15744.html (3.9 KB) - added by cjolif 7 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 7 years ago by Kitson Kelly

Description: modified (diff)

comment:2 Changed 7 years ago by cjolif

Owner: changed from Eugene Lazutkin to daniel.payne
Status: newpending

I'm sorry but your test sample relies on custom code (ertoc/app) would it be possible to provide us with a sample that does not rely on it? Or at least provide us with the exact error your are facing (line number...)?

Thanks.

Last edited 7 years ago by cjolif (previous) (diff)

comment:3 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:4 Changed 7 years ago by daniel.payne

sorry - you can remove ertpc/app from require and replace

app.initalise() WITH parser.parse();

comment:5 Changed 7 years ago by bill

Resolution: invalid
Status: closedreopened

comment:6 Changed 7 years ago by cjolif

Resolution: worksforme
Status: reopenedclosed

See the test case I attached. It is working without errors in the console in 1.8.0. So maybe it was a temporary problem in the RC or else please give us more information.

Changed 7 years ago by cjolif

Attachment: test_15744.html added
Note: See TracTickets for help on using tickets.