Opened 7 years ago

Closed 7 years ago

#15743 closed defect (invalid)

dijit.form.ValidationTextBox screen reader issue - a11y

Reported by: pierpaolo.manca Owned by: mikeb
Priority: undecided Milestone: tbd
Component: Accessibility Version: 1.6.1
Keywords: Cc: Douglas Hays
Blocked By: Blocking:

Description

The prompt/invalid message that appears in the tooltip beside the textbox is not readable by screen readers. When the user inserts an invalid value in the textbox, the content of the validation tooltip is not read out. The issue is reproducible on dojo 1.6.1 and JAWS 13.0.924

Change History (1)

comment:1 Changed 7 years ago by mikeb

Cc: Douglas Hays added
Resolution: invalid
Status: newclosed

Tested with dijit/tests/form/test_validate.html on the nightly build and the validation tooltip is read.

Tested with 1.6.1 and you're right, the tooltip is not read, however, JAWS does correctly say if the textbox is "invalid entry" or not.

I compared the two versions with Firebug and could not find any differences between the generated HTML code for either the dialog or the validation box. I was expecting that the fixed version would utilize some aria-* attributes (aria-labelledby?) but both versions have the same roles and attributes.

I think it is best to close this since it works in the nightly version...? I don't know the process to backport things, but if you need it backported then please help identify the changeset that fixed it and post it here.

Note: See TracTickets for help on using tickets.