Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15736 closed defect (fixed)

dojo/request/xhr exception when options not specified

Reported by: bill Owned by: Bryan Forbes
Priority: blocker Milestone: 1.8
Component: IO Version: 1.8.0rc1
Keywords: Cc:
Blocked By: Blocking:

Description

I tried to do this:

request(url)

According to xhr.js, the options parameter is optional:

function xhr(/*String*/ url, /*Object?*/ options, /*Boolean?*/ returnDeferred){

However, it isn't, because xhr() tries to access options.data:

has('native-formdata') && options.data && options.data instanceof FormData

While you are in that file, the description field is meaningless (because it says the same thing as the summary), and should be removed:

// summary:
//		Sends an HTTP request with the given URL and options.
// description:
//		Sends an HTTP request with the given URL.

Change History (5)

comment:1 Changed 7 years ago by Bryan Forbes

Milestone: tbd1.8
Priority: undecidedblocker

comment:2 Changed 7 years ago by Bryan Forbes

In [29380]:

Check options before options.data. refs #15736 !strict

comment:3 Changed 7 years ago by Bryan Forbes

In [29381]:

Remove description field. refs #15736 !strict

comment:4 Changed 7 years ago by Bryan Forbes

Resolution: fixed
Status: newclosed

comment:5 Changed 7 years ago by bill

#15823 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.