Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15731 closed defect (fixed)

[regression]dojox/html/_base set throws exception if parseContent is falsey

Reported by: Adam Peller Owned by: bill
Priority: high Milestone: 1.8
Component: Dojox Version: 1.8.0rc1
Keywords: Cc:
Blocked By: Blocking:

Description

regressed since 1.8.0b1

call set with parseContent unset or set to something falsey. _parse will not get called from onEnd in the dojo/html _ContentSetter superclass, leading to an exception because this.parseDeferred is undefined in the dojox onEnd method.

It's also interesting to note that the parser seemed to get called even when parseContent was falsey up until the 1.8.0rc1 release.

Attachments (1)

html.patch (1.1 KB) - added by bill 7 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 7 years ago by Adam Peller

Milestone: tbd1.8
Owner: changed from Adam Peller to bill
Priority: undecidedhigh
Status: newassigned

candidate for 1.8

comment:2 Changed 7 years ago by bill

Note: the only relevant tests we have for this code are in dojox/layout/tests/ContentPane.html, and dijit/layout/ContentPane (the superclass of dojox/layout/ContentPane) by default set parseContent: true, base on ContentPane's parseOnLoad attribute.

Changed 7 years ago by bill

Attachment: html.patch added

comment:3 Changed 7 years ago by bill

Resolution: fixed
Status: assignedclosed

In [29364]:

Fix exception in dojox/html/_base.set() when parseContent: false, fixes #15731 !strict.

comment:4 Changed 7 years ago by bill

#15762 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.