Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1573 closed defect (invalid)

LinkPane tab always preloading content

Reported by: ocryan@… Owned by: bill
Priority: high Milestone:
Component: Widgets Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

If you create a TabContainer? with a LinkPane? the content is always preloaded, even when the tab is not selected. Setting the preload="false" attribute has no effect, that's the default anyway. I have confirmed this by placing a breakpoint within the linked jsp page and the breakpoint is hit everytime the main page is loaded and without the tab being selected. It is my understanding that the content should not be loaded until AFTER the tab has been selected. This is much more optimal since many times the additional tab will never be selected and there's no need to fetch the content.

This is using the dojo toolkit version 0.3 downloaded from the main link at http://www.dojotookit.org on 9/25/2006

This is the first time I'm submitting an issue, and I mistakenly posted this as a new report accidentally, please remove report {16}, sorry!

Change History (2)

comment:1 Changed 13 years ago by bill

Resolution: invalid
Status: newclosed

You need to set style="display: none" on your linkpane. Then it won't preload.

comment:2 Changed 12 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.