Opened 7 years ago

Closed 7 years ago

#15724 closed defect (wontfix)

DateTextBox: drop down arrow changes size when clicked (claro, quirks)

Reported by: Mike Wright Owned by: Mike Wright
Priority: undecided Milestone: 1.9
Component: Dijit - Form Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

While trying the different themes I found the dijit.dateTextBox has a style bug only when using Claro.

When the "drop down arrow" at the right of the dateTextBox is clicked it changes size. This causes any date information in the input value to move.

This in not present in any of the other themes.

Attachments (2)

calendar.html (1.7 KB) - added by Mike Wright 7 years ago.
15724.patch (1.5 KB) - added by Douglas Hays 7 years ago.
fix

Download all attachments as: .zip

Change History (13)

comment:1 Changed 7 years ago by bill

Component: themesDojoX Form
Owner: changed from nonken to Mike Wright
Status: newpending
Summary: Claro style defect with dijit.dateTextBoxDateTextBox: drop down arrow changes size when clicked (claro)

I tried test_DateTextBox.html on FF/mac on 1.7.2 and trunk, and didn't notice any size change or shifting. What's your test case and browser?

comment:2 Changed 7 years ago by bill

Component: DojoX FormDijit - Form

comment:3 in reply to:  2 Changed 7 years ago by Mike Wright

Status: pendingnew

Replying to bill:

fedora 14-x86_64
firefox 13
chromium 12

The effect is not noticeable with the default style of "text-align: left" but when styled "center" or "right" it is noticeable.

Using Firebug's "computed style" I compared each of the four themes. The dijit's <input/> did not change upon clicking. The enclosing <div/> did but only on Claro, specifically the background-position.

Initial values were 100% 0% but upon clicking they changed to 0px -177px. The second value, when negative, is defined to move the background left, which it does.

Version 1, edited 7 years ago by Mike Wright (previous) (next) (diff)

comment:4 Changed 7 years ago by bill

Owner: changed from Mike Wright to Douglas Hays
Status: newassigned

OK, I'm not sure where you are setting text-align left, so as usual, please attach a test case using the "attach file" button. It should be as small as possible to still reproduce the problem, a single HTML file that we can load in the browser and use to reproduce then problem.

comment:5 in reply to:  4 Changed 7 years ago by Mike Wright

Replying to bill:

As to setting "text-align: left", I didn't. That's the way it renders in this example by default. I had to change it to "center" in order to demo the effect.

Last edited 7 years ago by Mike Wright (previous) (diff)

Changed 7 years ago by Mike Wright

Attachment: calendar.html added

comment:6 Changed 7 years ago by Douglas Hays

Milestone: tbd1.9

This is a quirks CSS problem. I'm always surprised to find this mode still being used.

Changed 7 years ago by Douglas Hays

Attachment: 15724.patch added

fix

comment:7 Changed 7 years ago by Douglas Hays

mikewright, please test with the attached patch. I'd also like to understand why you use quirks since I'd like to propose doing away with formal quirks support in 2.0.

comment:8 Changed 7 years ago by Douglas Hays

Owner: changed from Douglas Hays to Mike Wright
Status: assignedpending

mikewright, I don't have any of the test environments that you listed and would like a confirmation of the attached patch's effectiveness (and lack of side-effects) before committing it.

comment:9 in reply to:  7 Changed 7 years ago by Mike Wright

Status: pendingnew

Replying to doughays:

mikewright, please test with the attached patch. I'd also like to understand why you use quirks since I'd like to propose doing away with formal quirks support in 2.0.

I am unable to apply that patch. My 1.7.2 tree is gone and is no longer downloadable from the dojo site.

As for quirks: I didn't know I was. The word "quirks" doesn't appear in any of my code.

comment:10 in reply to:  8 Changed 7 years ago by Mike Wright

Replying to doughays:

mikewright, I don't have any of the test environments that you listed and would like a confirmation of the attached patch's effectiveness (and lack of side-effects) before committing it.

I no longer have that environment in order to verify.

At some time my html lost its doctype declaration. No idea when or how. HTML is only 20 lines. I always specify a dtd so I've never even looked back at the HTML launch page.

When I re-inserted the doctype at the top of the html document the anomaly disappeared.

(a little searching explained that quirks mode was because of a lack of a doctype declaration. I always try to use xhtml strict.)

I agree that quirks mode should be eliminated.

My sincerest apologies to you that I am unable to verify your efforts and thank you for all the effort you have expended.

comment:11 Changed 7 years ago by bill

Resolution: wontfix
Status: newclosed
Summary: DateTextBox: drop down arrow changes size when clicked (claro)DateTextBox: drop down arrow changes size when clicked (claro, quirks)

OK, sounds like it's not worth fixing (since it's just quirks mode).

Note: See TracTickets for help on using tickets.