Opened 7 years ago

Closed 7 years ago

#15716 closed defect (invalid)

TabContainer: default tab failing to change to an active state

Reported by: psiberia Owned by: psiberia
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.8.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

The following code in Dojo 1.8.0b1 fails to produce the expected result.

require(["dojo/ready", "dijit/layout/TabContainer", "dijit/layout/ContentPane"], function(ready, TabContainer?, ContentPane?){

ready(function(){

var tc = new TabContainer?({

style: "height: 100%; width: 100%;"

}, 'tabContainer');

var cp1 = new ContentPane?({

title: "Food", content: "We offer amazing food",

selected:true

}); tc.addChild(cp1);

var cp2 = new ContentPane?({

title: "Drinks", content: "We are known for our drinks."

}); tc.addChild(cp2);

tc.startup();

});

});

The default tab is not in the selected state as it should be. Selecting either tab does not change its state. Using Dojo 1.7.3 the code runs as expected.

Attachments (5)

Screen Shot 2012-07-18 at 10.21.03 PM.png (10.3 KB) - added by psiberia 7 years ago.
Dojo 1.8: Tab default state. first tab not selected.
Screen Shot 2012-07-18 at 10.21.16 PM.png (10.7 KB) - added by psiberia 7 years ago.
Dojo 1.8: Second tab selected. State remains unchanged.
Screen Shot 2012-07-18 at 10.23.08 PM.png (10.6 KB) - added by psiberia 7 years ago.
Dojo 1.7.3: Second tab selected and state changed as expected (same code)
Screen Shot 2012-07-18 at 10.22.58 PM.png (10.0 KB) - added by psiberia 7 years ago.
Dojo 1.7.3: Default tab in selected state (same code)
tab.html (794 bytes) - added by bill 7 years ago.
test case, works for me

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by psiberia

Dojo 1.8: Tab default state. first tab not selected.

Changed 7 years ago by psiberia

Dojo 1.8: Second tab selected. State remains unchanged.

Changed 7 years ago by psiberia

Dojo 1.7.3: Second tab selected and state changed as expected (same code)

Changed 7 years ago by psiberia

Dojo 1.7.3: Default tab in selected state (same code)

comment:1 Changed 7 years ago by bill

Owner: changed from bill to psiberia
Status: newpending
Summary: tabcontainer default tab failing to change to an active stateTabContainer: default tab failing to change to an active state

I tried this and it's working for me. Please attach a test case using the "attach file" button, a full HTML file that we can load in the browser and use to reproduce then problem. (You should do this for all tickets.)

I'll attach my test case that worked.

Changed 7 years ago by bill

Attachment: tab.html added

test case, works for me

comment:2 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.