Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#15712 closed defect (fixed)

test_Select innerHTML out of order in IE9 (1.8+)

Reported by: haysmark Owned by: Douglas Hays
Priority: low Milestone: 1.8
Component: Dijit - Form Version: 1.8.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

test_Select needs to use a more sophisticated equality test than comparing innerHTMLs. The problem is that in IE9, all of the attributes are there, but they print in a different than expected order. For instance, the test dojo.data store::test_changeSelected throws:

	expected
		<spanrole="option"class="dijitresetdijitinlinedijitselectlabeldijitvalidationtextboxlabel">alabama</span>
	but got
		<spanclass="dijitresetdijitinlinedijitselectlabeldijitvalidationtextboxlabel"role="option">alabama</span>

Also, the failure of this test case causes subsequent test cases to fail (they do not call setUp/tearDown).

Change History (4)

comment:1 Changed 7 years ago by haysmark

Milestone: tbdfuture
Priority: undecidedlow

comment:2 Changed 7 years ago by Douglas Hays

Milestone: future1.8
Status: newassigned
Version: 1.7.31.8.0b1

comment:3 Changed 7 years ago by Douglas Hays

Resolution: fixed
Status: assignedclosed

In [29323]:

Fixes #15712. Replace test method wrapLabel with a simple regexp that works everywhere.

comment:4 Changed 6 years ago by Douglas Hays

Summary: test_Select innerHTML out of order in IE9test_Select innerHTML out of order in IE9 (1.8+)

Not failing in < 1.8 since there's no role attribute added.

Note: See TracTickets for help on using tickets.