Opened 7 years ago

Closed 7 years ago

#15710 closed defect (duplicate)

Localization Error on Built Dojo - language = en

Reported by: Pete Smith Owned by: Adam Peller
Priority: undecided Milestone: tbd
Component: Internationalization Version: 1.7.3
Keywords: Cc: Rawld Gill
Blocked By: Blocking:

Description

I have been testing my app with the default locale on my browser "en-us" and it has been fine, both built and unbuilt. If I change my browser to just "en", the unbuilt (src) version works fine. If I build dojo, I don't get localization for my widgets anymore. If I do en-us it works great.

Change History (5)

comment:1 Changed 7 years ago by Adam Peller

Cc: Rawld Gill added

httpete - are you using 1.7.3 or trunk?

building en-us should build resources for 'en' and 'en-us' (possibly skipping en-us if no variants are present)

dup of #15324?

comment:2 Changed 7 years ago by Pete Smith

1.7.3 peller should I just go for 1.8?

comment:3 in reply to:  2 Changed 7 years ago by Rawld Gill

Replying to httpete:

1.7.3 peller should I just go for 1.8?

Try manually putting http://bugs.dojotoolkit.org/changeset/29259/dojo into dojo/i18n.js on your local machine--it requires deleting 3 characters in that file. Don't forget to rebuild to see the change.

Let me know how it turns out.

comment:4 Changed 7 years ago by Pete Smith

I simply took this file: http://bugs.dojotoolkit.org/browser/dojo/dojo/trunk/i18n.js?rev=29259

copied it over mine, and it works great, thanks Peller.

comment:5 Changed 7 years ago by Adam Peller

Resolution: duplicate
Status: newclosed

and thanks, rawld. Closing as dup, and will reopen #15324 to be considered for the 1.7 branch.

Note: See TracTickets for help on using tickets.