Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15707 closed defect (fixed)

various files missing in created archive

Reported by: Chris2 Owned by: James Thomas
Priority: undecided Milestone: 1.8.1
Component: WebBuilder Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

Hi guys, i want to create a dojo build consisting of dijit.form.CheckBox? dijit.form.RadioButton? dijit.form.TextBox? dijit.registry dojo.dom dojo.domReady dojox.av.FLVideo

By doing so i have noticed that following files are missing in the created archive: themes/dijit.css icons/commonIcons.css dojox/av/resources/video.swf

Do i need to select some special modules to get those files included in the created archive?

Change History (9)

comment:1 Changed 7 years ago by James Thomas

By default, we include the "claro" theme when you include a dijit widget, this contains all the parent "dijit.css" contents. Unfortunately, it's not possible to know all the required external resources for a JS module (e.g. that video.swf is needed) during the build process, without manually investigating each module by hand. If you are having trouble with these missing files, the easiest thing to do is copy them across manually from a copy of the source distribution. Does that help?

Thanks for taking the time to report this issue.

comment:2 Changed 7 years ago by Chris2

I already copied those files by hand. Actually i don't understand why dijit.css is not added automatically when a dijit-module is included in the build. Why not just enabling the user to add those missing files via the WebBuilder?? i.e. dojox/av/resources/video.swf Or adding custom files in general? i.e. language resources

Those missing files are not that much i guess, why not keeping a list of depending modules to each of those files which could be maintained in the WebBuilder? by the WebBuilder?-users?

comment:3 Changed 7 years ago by James Thomas

Resolution: wontfix
Status: newclosed

We already add the "claro" theme CSS file which contains the contents of "dijit.css" whenever you include a dijit-module. I'm looking at adding languages resource addition in the future, there's a balance between letting you replicate the full power of a normal Dojo build with the tool and overwhelming new users who just want a simple build. Thanks for the feedback.

comment:4 in reply to:  3 Changed 7 years ago by Chris2

Replying to jamesthomas:

We already add the "claro" theme CSS file which contains the contents of "dijit.css" whenever you include a dijit-module.

Thats not the point. The problem is that firefox/firebug reports the missing resource "themes/dijit.css". So it is still referenced somewhere even if it is already included in the theme.

Why is it not possible to reopen a ticket (for me)?

comment:5 Changed 7 years ago by James Thomas

Tickets can only be re-opened by users with committeer access I'm afraid. I'm not going to fix this issue because I think there's multiple valid work arounds (use claro.css in your pages/run the full build locally/copy dijit.css from source distrib.) and I don't believe it's worth including dijit.css in every build output when we're already including the claro theme, so it should stay close. I do appreciate you taking the time to provide feedback on the tool but I have to strike a balance between usability of the tool versus adding more features.

comment:6 Changed 7 years ago by Chris2

I think we've got a little missunderstanding here. :) That dijit.css is not included by me but by a dijit i am using. claro.css is the only css which i am referencing. Of course copying dijit.css solves the problem but also it makes the usage of WebBuilder? obsolete when the downloaded package is not out of the box usable. The WebBuilder? should simplify creating an own build, right? Therefore we could suppose that the average WebBuilder? users are not experienced at creating an own dojo-build. They probably try the WebBuilder?, see that their projects have errors now and therefore stick with source distrib or using CDN. Its your decision to address this issue. i understand that you got better things to do. but i guess i am not the only one who tried to create a custom build with some dijit-widgets. ;)

comment:7 Changed 7 years ago by James Thomas

Resolution: wontfix
Status: closedreopened

Apologies Chris, I misread the ticket. I can see the issue now, the dijit.css file isn't being inlined! This should be happening automatically, I'll re-open this ticket and investigate.

comment:8 Changed 7 years ago by James Thomas

Resolution: fixed
Status: reopenedclosed

I've tracked down the issue and put a fix in, can you try again? Re-open the ticket if it's still broken.

comment:9 Changed 7 years ago by bill

Milestone: tbd1.8.1
Note: See TracTickets for help on using tickets.