Opened 7 years ago

Closed 4 years ago

#15685 closed enhancement (patchwelcome)

Calendar: typematic for year selection

Reported by: Mike Wright Owned by: bill
Priority: low Milestone: 1.13
Component: Dijit Version: 1.7.3
Keywords: Cc:
Blocked By: Blocking:

Description

(it was recommended that I repost my email to the user list here; first post, hope this is the right way)

The dateTextBox has years at the bottom of the calendar. To move to a previous or following year requires a mouse click.

If a dateTextBox were used to, for example, "Enter your Date of Birth", my arthritic 90 something year old great grandmother would be sitting there for the next four hours clicking with a crippled hand and not enjoying a bit of it.

Would it be possible to enhance the dijit so that clicking and holding down the mouse button would let the years (in|de)crement until the mouse button is released, preferably with an accelerator (at 1 sec. intervals 90 years is a minute and a half. At 90 one is running out of time ;)?

This is a type of accessibility issue. Since the fastest growing internet demographic is between 70 and 75 years of age it would help a great many of our newest users.

Change History (7)

comment:1 Changed 7 years ago by Douglas Hays

Component: Dijit - FormDijit
Owner: changed from Douglas Hays to bill
Status: newassigned
Summary: dateTextBox change year requires too many clicksCalendar change year requires too many clicks

comment:2 Changed 7 years ago by bill

Resolution: duplicate
Status: assignedclosed

Duplicate of #10002.

comment:3 Changed 7 years ago by bill

Resolution: duplicate
Status: closedreopened
Summary: Calendar change year requires too many clicksCalendar: typematic for year selection

On second thought I should treat this as a separate ticket. It's coupled with #6570, but asking for something simpler than #10002.

Actually, Calendar used to work this way, until [24583]. I think I meant to exclude typematic support from CalendarLite, but I forget my intentions for Calendar.

comment:4 in reply to:  3 Changed 7 years ago by Mike Wright

comment:5 Changed 7 years ago by bill

Priority: undecidedlow

comment:6 Changed 7 years ago by bill

Milestone: tbdfuture

comment:7 Changed 4 years ago by dylan

Milestone: future1.12
Resolution: patchwelcome
Status: reopenedclosed

Given that no one has shown interest in creating a patch in the past 3+ years, I'm closing this as patchwelcome.

Note: See TracTickets for help on using tickets.