Opened 7 years ago

Closed 7 years ago

#15663 closed defect (fixed)

[regression] dojo.xhr() swallowing errors in callback

Reported by: bill Owned by: Bryan Forbes
Priority: blocker Milestone: 1.8
Component: IO Version: 1.7.3
Keywords: Cc:
Blocked By: Blocking:

Description

Not sure if this is intentional or not, but dojo.xhr() used to print errors to the console when the callback threw, and now it doesn't.

From any dojo test page (I'm using dijit/tests/mobile.html), try running this in firebug:

dojo.xhrGet({
   async: true,
   url: "/trunk/dijit/templates/Menu.html",
   load: function(data){ throw new Error("hi") }
})

(adjust the URL to match your system)

May be the cause of #15662.

Change History (2)

comment:1 Changed 7 years ago by Bryan Forbes

In [29260]:

Fix dojo.xhr* swallowing errors in callbacks. refs #15663 !strict

comment:2 Changed 7 years ago by Bryan Forbes

Milestone: tbd1.8
Priority: undecidedblocker
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.