Opened 7 years ago

Closed 7 years ago

#15625 closed defect (duplicate)

Incorrect aria-value-now/aria-value-min/aria-value-max for TimeTextBox and DateTextBox?

Reported by: Paul Christopher Owned by: mikeb
Priority: undecided Milestone: tbd
Component: Accessibility Version: 1.7.3
Keywords: Cc:
Blocked By: Blocking:

Description

TimeTextBox has

aria-valuenow="Thu Jan 01 1970 10:00:00 GMT+0100"

However, a TimeTextBox is about time only. No dates are necessary like "Thu Jan 01 1970". I'm not sure, whether this is announced by a screenreader. If so: It could be annoyning for those users.

On the other hand DateTextBox has

aria-valuenow="Fri Sep 28 2012 00:00:00 GMT+0200"

aria-valuemin="Fri Jul 06 2012 13:30:15 GMT+0200"

But DateTextBoxs are about dates only. No time stamps such as "13:30:15 GMT+0200" seem to be necessary. They could be confusing, too.

Change History (1)

comment:1 Changed 7 years ago by mikeb

Resolution: duplicate
Status: newclosed

Hello. I tested these attributes with JAWS13 on FF12, and JAWS does not read any of the aria-value* attributes (valuenow, valuemax, valuemin.) This is probably because they have role="textbox". Like I mentioned in #15052, I think that the spec is invalid and needs more range child widgets.

Even though they are slightly different I'm going to mark this a duplicate of #15052 because they should be fixed by the same patch.

Note: See TracTickets for help on using tickets.