Opened 7 years ago

Closed 7 years ago

#15624 closed defect (fixed)

dojox.image.LightboxDialog loosing css classes

Reported by: Saurabh Gupta Owned by: Saurabh Gupta
Priority: undecided Milestone: 1.8
Component: Dojox Version: 1.7.3
Keywords: Cc:
Blocked By: Blocking:

Description

Hey,

I have a dojox.image.LightboxDialog? that I'm showing on an image click. I overrode the "dojoxLightboxImage" & "dojoxLightboxFooter" classes to have custom css for the image & title being displayed.

When I click an image the very first time, the dialog comes up with the proper css. However, post that the css goes missing from the dialog...i.e. when you click an image & the lightbox dialog pops up, it doesn't have the css for the image & title.

It turned out that the the above mentioned classes were no longer assigned the second time onwards. The "imageNode" & "titleNode" no longer have have "dojoxLightboxImage" & "dojoxLightboxFooter" assigned to them respectively.

Doing

dialog.show({
    title:'${metadataLabel}', href:'${image}'
})

sets up the custom css the first time & them forgets about it henceforth.

Change History (6)

comment:1 Changed 7 years ago by Adam Peller

Owner: changed from Adam Peller to dante
Status: newassigned

comment:2 Changed 7 years ago by dante

Milestone: tbd1.8

I see where the class name on the <img> node itself goes missing. That will be trivial to fix. I am unable to reproduce a case where

dojo.query(".dojoxLightboxFooter");

doesn't return the $titleNode currently showing. Are you possibly mistaken on the footer class missing? Can you provide steps to reproduce? Commit coming for dojoxLightboxImage class being reset when image is torn down.

comment:3 Changed 7 years ago by dante

In [29149]:

refs #15624 - re-apply the classname to the image node when we need to swap it out

comment:4 Changed 7 years ago by dante

Owner: changed from dante to Saurabh Gupta
Status: assignedpending

comment:5 Changed 7 years ago by Saurabh Gupta

Status: pendingnew

Hey,

Sorry for the delayed reply - work kept up frantic pace!

Well, I didn't try to test for the footer separately.But I can confirm that in my usecase(the one mentioned on the ticket), I found both of them(the image & footer node) were missing the said css classes.

Please feel free to trust your own investigations:) They would tend to be more thorough than the one usecase I have outlined!

Hope this helps & please get back to me if you need anything else.

Cheers, S.

comment:6 Changed 7 years ago by dante

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.