Opened 7 years ago

Closed 7 years ago

#15621 closed defect (invalid)

Dojo project can not be started locally

Reported by: Ruth Lang Owned by:
Priority: undecided Milestone: tbd
Component: General Version: 1.7.3
Keywords: Cc:
Blocked By: Blocking:

Description

A dojo project can not be started locally with IE9 and Opera. The same project works locally well with Dojo 1.6.1. There is no problem with FF and Safari

This is the error message from IE (sorry in german):

Meldung: Zugriff verweigert Zeile: 15 Zeichen: 2943 Code: 0 URI: file:///E:/wwwroot/Mappetizer/dojoroot/dojo/dojo.js

Change History (1)

comment:1 Changed 7 years ago by bill

Resolution: invalid
Status: newclosed

This really isn't a dojo issue, it's just something that doesn't work well with browsers, by design. I'd really recommend testing via apache, or your favorite web server. It can run on your local machine.

Some browsers have configuration flags you can set (see http://dojo-toolkit.33424.n3.nabble.com/How-can-I-debug-run-local-javascript-file-locally-td3648920.html) to allow access over file://, but not sure about IE9.

Also, not sure if your results will vary if you set async:true and use AMD syntax to load the javascript files. Probably not, since you'd still be using XHR to load the templates for widgets.

Note: See TracTickets for help on using tickets.