Opened 7 years ago

Closed 7 years ago

#15614 closed defect (invalid)

_ComboBoxMenuMixin inserts [opbject HTML DivElement?] as menu item

Reported by: neel_basu Owned by: neel_basu
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.7.3
Keywords: Cc: Douglas Hays
Blocked By: Blocking:

Description

Line 86 of _ComboBoxMenuMixin.js

menuitem.innerHTML = labelObject.label;

is making HTML menu items [opbject HTML DivElement?]. this is solved by changing this to

dojo.place(labelObject.label, menuitem);

Change History (2)

comment:1 Changed 7 years ago by bill

Cc: Douglas Hays added
Component: GeneralDijit - Form
Owner: set to neel_basu
Status: newpending

That's hard to believe. You are saying that ComboBox's don't work at all and no one has noticed it before?

Please attach a test case using the "attach file" button. It should be as small as possible to still reproduce the problem, almost always a single HTML file that we can load in the browser and use to reproduce then problem.

Then, give exact instructions on how to reproduce the problem using your attached test file.

The test case is necessary both to confirm that there's a bug, and for us to be able to debug the problem.

Thanks!

comment:2 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.