Opened 7 years ago

Closed 7 years ago

#15605 closed defect (fixed)

Dialog: ESC doesn't close after click on background

Reported by: bill Owned by: bill
Priority: low Milestone: 1.9
Component: Dijit Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

Reported broken starting in [23488],

  1. Press "Show Dialog" in test_Dialog.html
  2. Click somewhere in the dialog but not on a control (ex: to the right of the first <input>)
  3. Press ESC key
  4. Dialog won't close.

In 1.5 that click "on nothing" would focus the Dialog itself, but now it focuses nothing.

I don't think there's an accessibility issue though, because if a user clicked the dialog once to defocus, then they can click again to refocus an input, or to close the Dialog (by clicking the X icon).

Change History (5)

comment:1 Changed 7 years ago by bill

Description: modified (diff)
Priority: undecidedlow

comment:2 Changed 7 years ago by bill

#15699 is a duplicate of this ticket.

comment:3 Changed 7 years ago by bill

Milestone: tbdfuture

comment:4 Changed 7 years ago by bill

Milestone: future1.9
Status: newassigned
Summary: Dialog: ESC doesn't close after clickDialog: ESC doesn't close after click on background

comment:5 Changed 7 years ago by bill

Resolution: fixed
Status: assignedclosed

In [30967]:

make ESC close Dialog even after clicking page background, fixes #15605 !strict

Note: See TracTickets for help on using tickets.