Opened 7 years ago

Closed 7 years ago

#15603 closed defect (duplicate)

dialog requests focus on destroy

Reported by: tanneman Owned by: bill
Priority: undecided Milestone: 1.7.3
Component: Dijit Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

I get a script error on IE8 when leaving my application. With the debugger I found that the Dialog.destroy() calls DialogLevelManager?.hide(this). And the DialogLevelManager?.hide() tries to focus the dialog if refocus is set to true. So the fix is to let the destroy set the refocus flag to false since it is about to be destroyed.

Change History (1)

comment:1 Changed 7 years ago by bill

Milestone: tbd1.7.3
Resolution: duplicate
Status: newclosed

Duplicate of #15058.
Should be fixed in 1.7.3

Note: See TracTickets for help on using tickets.