Opened 7 years ago

Closed 6 years ago

#15602 closed defect (fixed)

Dialog: popups don't close when dragging a dialog (IE9)

Reported by: dragonli Owned by: bill
Priority: low Milestone: 1.9
Component: Dijit Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

steps to reproduce the problem:

1) Create a dijit dialog

2) Add a ComboBox widget in the dialog

3) In IE9, when dragging&moving the dialog, the Combobox Menu of the widget is not released.

Note: it only happens in IE9. Suspect that the onBlur event is not triggered by dragging the dialog. Many thanks

Attachments (2)

ComboboxDragIssue.png (10.3 KB) - added by dragonli 7 years ago.
testDialog.html (4.5 KB) - added by Paul Christopher 7 years ago.

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by dragonli

Attachment: ComboboxDragIssue.png added

comment:1 Changed 7 years ago by bill

Description: modified (diff)
Priority: undecidedlow
Summary: In IE 9 , ComoBoxMenu can not be released when dragging the container - dijit buttonDialog: popups don't close when dragging a dialog (IE9)

I'll try to reproduce although it's always better if you attach a test case.

comment:2 Changed 7 years ago by Paul Christopher

Yes, it think this is correct. For some reason, using IE9, the ComboBox is not closed when dragging the dialog, see testcase attached. The same thing happens when a FilteringSelect is used.

Changed 7 years ago by Paul Christopher

Attachment: testDialog.html added

comment:3 Changed 7 years ago by bill

Ok. Thanks for the test case!

comment:4 Changed 7 years ago by Paul Christopher

However it doesn't matter whether the FilteringSelect or ComboBox is inside a dialog or not: the event (blur?) responsible for closing the drop down is not fired(?)/ fails(?) on IE9.

The aftereffects are the same as already reported in http://bugs.dojotoolkit.org/ticket/5777.

comment:5 Changed 7 years ago by bill

Milestone: tbdfuture

comment:6 Changed 6 years ago by bill

Milestone: future1.9
Resolution: fixed
Status: newclosed

This is no longer an "issue" because now on IE9, the drop down is dragged with the Dialog, thanks to [30911].

Note: See TracTickets for help on using tickets.