Opened 7 years ago

Closed 7 years ago

#15593 closed defect (invalid)

TextBox style regression - missing style from iphone.css

Reported by: Rick Lacy Owned by: Eric Durocher
Priority: undecided Milestone: tbd
Component: DojoX Mobile Version: 1.8.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

In playing around with 1.8.0b1, I noticed my text boxes looked bad because the border radius was gone. I looked at iphone.css etc and it appears that the @import url("TextBox?.css") was removed. It seems like this is a problem since it will change the text box style on apps.

Or if there's a new way I'm supposed to be including this css file, please let me know.

Change History (4)

comment:1 Changed 7 years ago by Eric Durocher

The TextBox.css import was replaced by the SearchBox.css import, which in turn imports TextBox.css, so nothing should change. I did a quick test with the beta and the TextBox radius seems OK.

Are you using the source distribution of the beta? Do you have SearchBox.css? Can you attach a small running sample that reproduces the problem?

comment:2 Changed 7 years ago by Rick Lacy

Ah, I think I see the problem. I was using RAD from IBM and the version I was actually running against was 1.7.2-20120420-IBM, which I mistook for my 1.8.0b1 workspace because for some reason they decided to include some of the new widgets from 1.8. They included the rogue css files with bits like Accordion.css and SimpleDialog?.css but with SearchBox?.css (and TextBox?.css) removed.

So it looks like it's IBM's custom version that is messed up. I retested with the *real* 1.8 beta and it was ok. If you know someone from IBM who works on this, please pass this on.

Sorry for my confusion.

comment:3 Changed 7 years ago by Rick Lacy

I did what I could for this, opening a thread on IBM's site -

https://www.ibm.com/developerworks/forums/thread.jspa?threadID=439292

comment:4 Changed 7 years ago by Eric Durocher

Resolution: invalid
Status: newclosed

OK, I'll make sure this is handled on the IBM side. Thanks for reporting this.

Note: See TracTickets for help on using tickets.