Opened 7 years ago

Closed 5 years ago

#15578 closed defect (fixed)

[patch][cla] Editor in IE<9 gets the internal carat wrong when collapsing a text node selection

Reported by: Bryan Forbes Owned by: Jared Jurkiewicz
Priority: high Milestone: 1.8
Component: Editor Version: 1.8.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

I'm attaching a test case and patch to fix an issue where the following code, in IE<9, incorrectly moves the cursor when it is at the beginning of a line:

editor._moveToBookmark(editor._getBookmark());

In the test, the cursor must be placed at the beginning of the line with the text "three" to see the problem running that code.

Attachments (5)

editor.html (1013 bytes) - added by Bryan Forbes 7 years ago.
range-fix.diff (650 bytes) - added by Bryan Forbes 7 years ago.
range-fix.2.diff (469 bytes) - added by Bryan Forbes 7 years ago.
test.patch (2.6 KB) - added by bill 7 years ago.
test case, except I'm not sure what the expected behavior is, I'm seeing the same thing on FF and IE9
15578.patch (2.4 KB) - added by Jared Jurkiewicz 7 years ago.
Updated testcase that should be more correct. Requires more testing.

Download all attachments as: .zip

Change History (17)

comment:1 Changed 7 years ago by Bryan Forbes

Milestone: tbd1.8
Owner: set to liucougar
Priority: undecidedhigh
Status: newassigned

Changed 7 years ago by Bryan Forbes

Attachment: editor.html added

Changed 7 years ago by Bryan Forbes

Attachment: range-fix.diff added

Changed 7 years ago by Bryan Forbes

Attachment: range-fix.2.diff added

Changed 7 years ago by bill

Attachment: test.patch added

test case, except I'm not sure what the expected behavior is, I'm seeing the same thing on FF and IE9

comment:2 Changed 7 years ago by bill

Owner: changed from liucougar to Jared Jurkiewicz

comment:3 Changed 7 years ago by Jared Jurkiewicz

Resolution: fixed
Status: assignedclosed

In [29320]:

Fixing IE9 specific issue with caret in the wrong spot. fixes #15578

comment:4 Changed 7 years ago by bill

Resolution: fixed
Status: closedreopened

Does this really work for you? The test is failing for me on both IE8 and FF.

comment:5 Changed 7 years ago by bill

In [29377]:

temporarily comment out broken test, refs #15578

Changed 7 years ago by Jared Jurkiewicz

Attachment: 15578.patch added

Updated testcase that should be more correct. Requires more testing.

comment:6 Changed 7 years ago by Colin Snover

Milestone: 1.82.0

1.8 has been tagged; moving all outstanding tickets to next major release milestone.

comment:7 Changed 7 years ago by bill

Milestone: 2.01.9

comment:8 Changed 6 years ago by bill

Milestone: 1.91.10

Bumping this ticket since we are past the deadline for the 1.9RC. The fix can be put into 1.9.1 too, if desired.

comment:9 Changed 6 years ago by dylan

Owner: changed from Jared Jurkiewicz to bpayton
Status: reopenedassigned
Summary: Editor in IE<9 gets the internal carat wrong when collapsing a text node selection[patch][cla] Editor in IE<9 gets the internal carat wrong when collapsing a text node selection

comment:10 Changed 5 years ago by bill

To reproduce problem from a user's perspective:

  1. backup to before patch:
$ git checkout 7f59a92a765a58ee8090b63f1f849b0031b429ef~1
  1. load editor.html on IE8
  1. click at start of word "three" then click indent button

Expected behavior: "three" indented. Not added to list, but indented:

  • one
  • two

three

  • four
  • five

Actual behavior: "two" list item doubly indented:

  • one
    • two

three

  • four
  • five
Last edited 5 years ago by bill (previous) (diff)

comment:11 Changed 5 years ago by bill

Milestone: 1.101.8
Owner: changed from bpayton to Jared Jurkiewicz

Note that ideally "three" would become part of the list, but that's not what currently happens, even after Jared's patch.

I will fix the test case to match the current behavior and then close this ticket. Since the actual bug (about list item "two" getting double-indented) was fixed in 1.8, marking the milestone as 1.8.

comment:12 Changed 5 years ago by Bill Keese <bill@…>

Resolution: fixed
Status: assignedclosed

In a6ab60a71eb04ec6f2f075d5dd131e4068f1f691/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.