Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15565 closed defect (fixed)

IE9 and embedded dojo page within an iframe: scrollIntoView fails, thus selecting entries from a FilteringSelect not possible

Reported by: Paul Christopher Owned by: Douglas Hays
Priority: undecided Milestone: 1.6.2
Component: Core Version: 1.7.3
Keywords: Cc:
Blocked By: Blocking:

Description

Description

Dojo throws an exepction in dojo/window.js after having processed line 90 when trying to scroll a node into view: "Error: scrollIntoView: Access denied".

This is quite a blocker since scrollIntoView is used by _ListBase to select an item e.g. in a drop down of a FilteringSelect. And if a webpage embeds another webpage using an iframe, the FilteringSelects of the embeded page do not work properly.

Steps to reproduce the issue

  • Unzip the attached testcase. Run testFilteringSelectFrame_ERROR.html which actually embeds testFilteringSelect.html.
  • Open the drop down by clicking on the arrow icon with your mouse. This already triggers the above error.
  • Next grib the handle of the drop down's scroll bar with the mouse and scroll down to the very end.
  • Try to select the last item: This does not work. Spurious scroll events make it nearly impossible to select an entry.
  • Next run the file testFilteringSelectFrame_OK.html. There are no errors. Everything works fine. The only difference between those two files is that the latter uses src="testFilteringSelect.html" to embed the test page containg the FilteringSelect, the former, error prone page src="http://127.0.0.1:8080/TestLoader1-7-2/testFilteringSelect.html"

Discussion

No idea why the url makes a difference. However an embedded dojo page should work always like a charm regardeless who embeds it?

Affected browser

IE9 only

Attachments (1)

testcase.zip (2.0 KB) - added by Paul Christopher 7 years ago.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by Paul Christopher

Attachment: testcase.zip added

comment:1 Changed 7 years ago by bill

Owner: set to Douglas Hays
Status: newassigned

Doug, can you take this one, since it's about scrollIntoView()?

comment:2 Changed 7 years ago by Douglas Hays

Milestone: tbd1.8

comment:3 Changed 7 years ago by Douglas Hays

Resolution: fixed
Status: assignedclosed

In [29051]:

Fixes #15565. Remove frameElement evaluation from another document to avoid access exceptions in IE9. !strict

comment:4 Changed 7 years ago by Douglas Hays

In [30339]:

Refs #15565. Backport [29051] to 1.6/1.7 to support IE 9/10. !strict

comment:5 Changed 7 years ago by Douglas Hays

Milestone: 1.81.6.2
Note: See TracTickets for help on using tickets.