Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15556 closed defect (duplicate)

1.7.3 release missing internally referenced NLS files

Reported by: mdorman@… Owned by: Adam Peller
Priority: undecided Milestone: 1.7.4
Component: Internationalization Version: 1.7.3
Keywords: Cc: Colin Snover, Douglas Hays, Rawld Gill
Blocked By: Blocking:

Description

The 1.7.3 release in all forms I could check (svn tag, github tag, tarball, unpacked directory on download.dojotoolkit.org) is missing a number of cldr files that are referenced elsewhere. This causes errors during custom builds of the form:

 error(354) Root bundle indicates localized bundles that don't exist. Root: dojo/cldr/nls/islamic; missing bundles: 'fr','hu','it','nb','nl','pl','pt','pt-pt','ru','sv','th','tr','zh'.
 error(354) Root bundle indicates localized bundles that don't exist. Root: dojo/cldr/nls/buddhist; missing bundles: 'fr','hu','it','ja','ko','nb','nl','pl','pt','pt-pt','ru','sv','tr','zh'.
 error(354) Root bundle indicates localized bundles that don't exist. Root: dojo/cldr/nls/hebrew; missing bundles: 'fr','hu','nl','ru','sv','th','tr'.

The files exist in the repository, just not, as far as I can tell, in the appropriate tags.

Change History (10)

comment:1 Changed 7 years ago by Adam Peller

Cc: Colin Snover Douglas Hays added

comment:2 Changed 7 years ago by Colin Snover

Cc: Rawld Gill added

comment:3 Changed 7 years ago by kurtjlidl

I see this error as well, when I updated my application to build with the 1.7.3 release of dojo. I did not have this error with r27919 of the util directory.

comment:4 Changed 7 years ago by kurtjlidl

This appears to basically be the same problem as bug #15288, which was resolved several weeks ago. I'd guess the changeset for that bug would fix this problem for 1.7.3 too.

comment:5 Changed 7 years ago by Colin Snover

The patch on #15288 does not apply cleanly to the branch. I can’t actually tell that this is causing build failures, just errors in the nls flattening part. Nevertheless it looks bad so we will probably need to fix and release a 1.7.4.

comment:6 Changed 7 years ago by Adam Peller

Yes, looks like an oversight on my part. #15288 should have been applied to 1.7.x, given Rawld's new checks. OTOH, it's just a check, not a regression since 1.7.2, so I'd suggest we put it in the 1.7 branch but not push 1.7.4 only to fix this bug.

comment:7 Changed 7 years ago by Adam Peller

Milestone: tbd1.7.4

comment:8 Changed 7 years ago by Kitson Kelly

Do we need to do anything with this before we cut 1.7.4?

comment:9 Changed 7 years ago by Adam Peller

Resolution: duplicate
Status: newclosed

dup of #15288

comment:10 Changed 7 years ago by Adam Peller

Failed to add these files from my machine. When I tried from one of the sandbox machines, it said svn was out of date.

` Adding fr/buddhist.js Adding fr/hebrew.js Adding fr/islamic.js Adding hu/buddhist.js Adding hu/hebrew.js Adding hu/islamic.js Adding it/buddhist.js Adding it/islamic.js Adding ja/buddhist.js Adding ko/buddhist.js Adding nb/buddhist.js Adding nb/islamic.js Adding nl/buddhist.js Adding nl/hebrew.js Adding nl/islamic.js Adding pl/buddhist.js Adding pl/islamic.js Adding pt/buddhist.js Adding pt/islamic.js Adding pt-pt/buddhist.js Adding pt-pt/islamic.js Adding ru/buddhist.js Adding ru/hebrew.js Adding ru/islamic.js Adding sv/buddhist.js Adding sv/hebrew.js Adding sv/islamic.js Adding th/hebrew.js Adding th/islamic.js Adding tr/buddhist.js Adding tr/hebrew.js Adding tr/islamic.js Adding zh/buddhist.js Adding zh/islamic.js Transmitting file data ............svn: Commit failed (details follow): svn: PUT of '/src/!svn/wrk/f8ce0033-8f3b-49ae-9fac-db43d0bd2a8c/branches/1.7/dojo/cldr/nls/nl/islamic.js': SSL negotiation failed: SSL error: bad decompression (https://svn.dojotoolkit.org) `

Version 0, edited 7 years ago by Adam Peller (next)
Note: See TracTickets for help on using tickets.