Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15550 closed defect (fixed)

[cla] [patch] Grid errors when navigating through cells w/last column hidden

Reported by: Karl Tiedt Owned by: Evan
Priority: undecided Milestone: 1.6.2
Component: DojoX Grid Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

reproducible here: http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/grid/tests/test_grid_column_display.html

On IE8:

When you are using the keyboard (right/left arrows) to navigated inside the grid on L2 panel, when you reach an item from the last column and then press again the right arrow from the keyboard, you'll get an "Out of memory" message.

On FF3.6:

When you reach the last column, press the right arrow once and then the left arrow. You will notice that the focus will move to the previous column pretty fast.

But when you reach the last column, if you press right arrow several times and then the left arrow, you will see that the focus moves to the previous column after few seconds.

Attachments (1)

1_7_2_15550.patch (582 bytes) - added by Karl Tiedt 7 years ago.
patch against 1.7.2 (just to illustrate the simple fix)

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by Karl Tiedt

Attachment: 1_7_2_15550.patch added

patch against 1.7.2 (just to illustrate the simple fix)

comment:1 Changed 7 years ago by Karl Tiedt

Attached is the patch our team has been using since they came across this a few months ago, if someone more in-tune with the inner workings of the Grid could review it (it appears to be working fine w/0 side affects on our end).

comment:2 in reply to:  1 Changed 7 years ago by Evan

Milestone: tbd1.7.4

Replying to ktiedt:

Attached is the patch our team has been using since they came across this a few months ago, if someone more in-tune with the inner workings of the Grid could review it (it appears to be working fine w/0 side affects on our end).

Thanks Karl,

Yep, the patch looks nice and fixed the issue, actually the issue exists on all browsers when there is a hidden column.

comment:3 Changed 7 years ago by Evan

Resolution: fixed
Status: newclosed

In [29004]:

Fixes #15550, thanks for ktiedt's patch, fix a potential dead recursive when navigating a hidden column. Also applied to 1.7.x branch

comment:4 Changed 7 years ago by Evan

In [29921]:

Refs #15550, also back port the fix to 1.6.x branch

comment:5 Changed 7 years ago by Evan

Milestone: 1.7.41.6.2
Note: See TracTickets for help on using tickets.