Opened 7 years ago

Closed 7 years ago

#15544 closed enhancement (duplicate)

AMD macro to load stylesheet

Reported by: haysmark Owned by: Rawld Gill
Priority: undecided Milestone: tbd
Component: Loader Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

It would be nice if we had a way to make widgets (like grid) load their own stylesheet.

Example:

     define([... "dojo/style!./MyWidget.css", ...],

Results in the following injected into <head>

<link rel="stylesheet" href="./MyWidget?.css" />

Currently, users have to remember to add the CSS for each dojox widget they use, which is very inconsistent with dijit.

Change History (1)

comment:1 Changed 7 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #5402.

Note: See TracTickets for help on using tickets.