Opened 7 years ago

Closed 7 years ago

#15542 closed defect (fixed)

[patch][ccla]The input node of the ValuePickerSlot looks not centered on iOS devices

Reported by: Soyhy Lim Owned by: Eric Durocher
Priority: undecided Milestone: 1.8
Component: DojoX Mobile Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

Platform: iOS devices only

Apparently, the ValuePicker? value node looks like it is pushed to the right and to the bottom of the input area, instead of being centered.

This bug is reproduced only on iOS devices. It is not introduced by the implantation of ticket #14919. In fact, it could also be reproduced with the Android theme of the previous implementation.

The reason is that, on iOS devices, the padding of that node is not set to zero by default. The fix is simply explicitly set the padding property to 0. See the attached patch.

Soyhy Lim (IBM, CCLA)

Attachments (1)

dojox-ticket_15542.patch (1.9 KB) - added by Soyhy Lim 7 years ago.
Soyhy Lim (IBM, CCLA): patch for #15542, padding: 0 for value picker input node

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by Soyhy Lim

Attachment: dojox-ticket_15542.patch added

Soyhy Lim (IBM, CCLA): patch for #15542, padding: 0 for value picker input node

comment:1 Changed 7 years ago by cjolif

Milestone: tbd1.8

comment:2 Changed 7 years ago by cjolif

Summary: The input node of the ValuePickerSlot looks not centered on iOS devices[patch][ccla]The input node of the ValuePickerSlot looks not centered on iOS devices

comment:3 Changed 7 years ago by cjolif

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.