Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15540 closed defect (duplicate)

Tooltip position for "Bars" chart is incorrect

Reported by: ngjaying2 Owned by: Eugene Lazutkin
Priority: undecided Milestone: tbd
Component: Charting Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

Steps to reproduce:

  1. Download the attached test case and put in dojox/charting/tests
  2. Run test_chart2d2.html
  3. Hover on the bars, you can find the tooltip is shown at the bottom of the page.

In dojox/charting/action2d/Tooltip.js, process function, the aroundRect is gotten by:

case "bar":
aroundRect = lang.clone(o.shape.getShape());
break;

In which aroudRect.w is NaN. But aroundRect.w is used later to calculate the position. I think this may be the cause of the problem

Attachments (2)

test_chart2d2.html (3.5 KB) - added by ngjaying2 7 years ago.
Testcase
test_chart2d2.2.html (3.6 KB) - added by cjolif 7 years ago.
fixed test case

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by ngjaying2

Attachment: test_chart2d2.html added

Testcase

comment:1 Changed 7 years ago by bill

Component: DojoX DrawingCharting
Description: modified (diff)
Owner: changed from Mike Wilcox to Eugene Lazutkin

comment:2 Changed 7 years ago by cjolif

Resolution: duplicate
Status: newclosed

Duplicate of #14650.
This is supposed to be already fixed in 1.7.3rc please check and if you still reproduce re-open with more details.

comment:3 Changed 7 years ago by ztmnb163

I tried it in Dojo 1.7.3, and the problem still exist(the tooltip is shown at the bottom of the page).

comment:4 Changed 7 years ago by cjolif

ztmnb163, maybe you are referring to another problem. If you are using the attached sample some CSS is missing in it. That might be your problem. I've attached a fixed test case. I suppose this will solve your problem.

Changed 7 years ago by cjolif

Attachment: test_chart2d2.2.html added

fixed test case

Note: See TracTickets for help on using tickets.