Opened 7 years ago

Closed 7 years ago

#15530 closed feature (duplicate)

Feature Request - Dojo build to use in Windows 8

Reported by: Stephen Chung Owned by:
Priority: undecided Milestone: tbd
Component: General Version:
Keywords: Cc:
Blocked By: Blocking:

Description

The up-coming release of Windows 8 enables Metro-style apps to be written entirely with JavaScript? + WinJS (Microsoft's linkage library).

However, there are restrictions in certain JavaScript? features that may be troublesome for vanilla Dojo. There are also some other quirks, e.g.

  • Only IE10+ (so no webKitMobile and probably needs a dedicated ie10 set of features)
  • No innerHtml
  • WinJS has its own set of Metro widgets, so no dijit -- but perhaps possible to wrap a dijit over the Metro widgets
  • dojox.mobile probably needs to be revised to fit into WinJS's page model

I believe that a WinJS-dedicated build of Dojo will be a great help getting Dojo established in the Windows 8 user base. No other library supports Windows 8 at this point (not even jQuery or any plugin), so everybody starts off at ground zero at the same time, and it is land-grab time.

Change History (1)

comment:1 Changed 7 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #16432.

Note: See TracTickets for help on using tickets.