Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15526 closed defect (fixed)

dojox.geo.charting: map not visible if DOCTYPE is specified in the HTML

Reported by: Adrian Vasiliu Owned by: Patrick Ruzand
Priority: undecided Milestone: 1.8
Component: Dojox Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

Strangely, all tests in dojox/geo/openlayers/tests and demos/mobileGeoCharting/demo.html have no DOCTYPE specified for their HTML, and after adding <!DOCTYPE HTML> (HTML5) in some of the tests the map becomes invisible or doesn't have the correct size. (Same result for the HTML4 doctype.) This holds for both dojo-trunk / Dojo 1.8 (as of 18 June 2012) and for the Dojo 1.7 branch.

Reproduced in various desktop and mobile browsers: Chrome 19, Firefox 12, iPhone iOS 5.01, HTC Desire Android 2.2.

This is the result of adding <!DOCTYPE HTML> to each test:

test_widget.html: => the map does not appear at all. test_europemaps.html and test_maps.html: => The maps does appear, but it is very small (does not fill the window anymore). test_mapWithCharting.html and test_mapWithLegend: => no visible difference of behavior.

A similar issue hurts for dojox.geo.openlayers (http://trac.dojotoolkit.org/ticket/15525 ).

Change History (6)

comment:1 Changed 7 years ago by Adam Peller

Owner: changed from Adam Peller to Eric Durocher
Status: newassigned

comment:2 Changed 7 years ago by Adam Peller

Owner: changed from Eric Durocher to Patrick Ruzand

comment:3 Changed 7 years ago by Patrick Ruzand

Regarding dojox/geo/charting, there's no issue per see in the lib code. The problem is on the tests/demos source code that widely use the "height:100%" style attribute, which does not have the same meaning in quirks mode vs standard mode. So, for the demos where the map appears smaller, it's due to the default map size (100x100). And it does not affect tesT_mapWithCharting and test_mapWithLegend because both have an explicit height value.

So nothing wrong in the lib code. Will fix the tests/demos though.

comment:4 Changed 7 years ago by Patrick Ruzand

Resolution: fixed
Status: assignedclosed

In [28922]:

add doctype, remove "height:100%" style attribute, fixes #15526

comment:5 Changed 7 years ago by Patrick Ruzand

In [28923]:

add doctype, remove "height:100%" style attribute, refs #15526

comment:6 Changed 7 years ago by bill

Milestone: tbd1.8
Note: See TracTickets for help on using tickets.