Opened 7 years ago

Closed 7 years ago

#15524 closed defect (fixed)

[regression]: IE6/7/8 file:/// fails starting with [28704]

Reported by: Douglas Hays Owned by: Bryan Forbes
Priority: high Milestone: 1.8
Component: IO Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by Douglas Hays)

It seems the new xhr code doesn't work with IE6/7/8's file:/// protocol. This works fine in 1.7 and in trunk until [28704]. Still broken as of r28907. The file:/// protocol does work on Chrome. Refs #15182. Fails on almost all dijit tests
(e.g. file:///e:/trunk/dijit/tests/form/test_Slider.html ).

Change History (4)

comment:1 Changed 7 years ago by Douglas Hays

Description: modified (diff)
Priority: undecidedhigh

comment:2 Changed 7 years ago by Douglas Hays

Milestone: tbd1.8

comment:3 Changed 7 years ago by Bryan Forbes

In [28925]:

Fix for file:/// not working in IE<9. refs #15524 !strict

comment:4 Changed 7 years ago by Bryan Forbes

Resolution: fixed
Status: newclosed

Even though file:/// is generally unsupported, I've patched this because it was a feature that worked in 1.7. I would expect file:/// not to work in 2.0.

Note: See TracTickets for help on using tickets.