Opened 7 years ago

Closed 3 years ago

#15514 closed defect (wontfix)

The colour contrast ratio for a disabled dijit.form.Button falls below minimum defined in WCAG 2.0 AA checkpoint 1.4.3

Reported by: jon.wollny Owned by: bill
Priority: undecided Milestone: 1.11
Component: Accessibility Version: 1.6.1
Keywords: Cc: Douglas Hays
Blocked By: Blocking:

Description

a11y details here: http://w3-03.ibm.com/able/devtest/webcontrast_aa.html http://www.w3.org/TR/UNDERSTANDING-WCAG20/visual-audio-contrast-contrast.html

The issue is the foreground colour defined in Button.css .tundra .dijitDisabled .dijitButtonText {

color: #7F7F7F;

}

If the colour is slightly darkened to #5D5D5D the contrast increases to 4.66 which passes.

Test case

Run contrast analyser http://www.paciellogroup.com/resources/contrast-analyser.html

Input these colours: foreground : #7F7F7F background : #E7E7E7(this is the colour of the disabled button image buttonDisabled.png, found in dojo16\dijit\themes\tundra\images)

The contrast is 3.24:1 which is below the 4.5:1 minimum.

Attachments (1)

Button.css.patch (346 bytes) - added by mikeb 6 years ago.
Increase contrast on disabled Tundra button to comply with WCAG2.0 accessibility requirements. Please proxy commit for Michael Billau, CCLA on file with IBM.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 6 years ago by kmadan

Hi, can someone please confirm if this accepted as an issue in Dojo and when will this be looked at..?

thanks Kapil

Changed 6 years ago by mikeb

Attachment: Button.css.patch added

Increase contrast on disabled Tundra button to comply with WCAG2.0 accessibility requirements. Please proxy commit for Michael Billau, CCLA on file with IBM.

comment:2 Changed 6 years ago by mikeb

Cc: Douglas Hays added

Hello, sorry for the late response. I have confirmed that using #5D5D5D does increase the contrast and have submitted a patch.

comment:3 Changed 6 years ago by Douglas Hays

In my opinion, the changed text color looks too much like the enabled text color after this change is applied. Also, I think only the claro theme has been instrumented to comply with accessibility guidelines.

comment:4 Changed 3 years ago by dylan

Milestone: tbd1.11
Owner: changed from mikeb to bill
Status: newassigned

Bill, do you think we should accept this change for Tundra, or close this ticket as wontfix based on the last comment from Doug Hays?

comment:5 Changed 3 years ago by bill

Resolution: wontfix
Status: assignedclosed

Let's just close it (for the reasons Doug said).

Note: See TracTickets for help on using tickets.