Opened 7 years ago

Closed 7 years ago

#15504 closed defect (fixed)

PasswordValidator: autofocus on verify with firefox

Reported by: Mathevet julien Owned by: dante
Priority: undecided Milestone: 1.8
Component: DojoX Form Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

first example: http://livedocs.dojotoolkit.org/dojox/form/PasswordValidator

If you set a password in "new" then you pass on second field ("verify"), it's hard to back to new field to change it. Each time you try to click on this field, it focus then on verify and say your password doesn't match. Only ALT+SHIFT+TAB works. You could reproduce with firefox

It could happen when user forget the given password and he want to retype again.

Change History (6)

comment:1 Changed 7 years ago by Mathevet julien

I think there are no need to focus on non valid fields. So patch could be trivial. See focus method at end of file.

comment:2 Changed 7 years ago by bill

Resolution: fixed
Status: newclosed

In [28963]:

Fix subclasses of ComboBox/FilteringSelect that specify an old dojo.data store as part of the prototype, rather than as a parameter to the constructor. Thanks Mark for the fix!

Fixes #15504 !strict.

comment:3 Changed 7 years ago by bill

Resolution: fixed
Status: closedreopened

Ugh, previous fix was for #15004, ignore entry here.

comment:5 Changed 7 years ago by Mathevet julien

Seem fixed outside this class. May be was more general problem.

you could close it

comment:6 Changed 7 years ago by bill

Milestone: tbd1.8
Resolution: fixed
Status: reopenedclosed

OK, I actually can't reproduce it even in 1.7.2, but I'll take your word for it.

Note: See TracTickets for help on using tickets.