Opened 7 years ago

Closed 7 years ago

#15501 closed defect (fixed)

drop-down menus fail in Mobile Safari

Reported by: Colin Snover Owned by: bill
Priority: blocker Milestone: 1.8
Component: Dijit Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

Repro:

  1. Load dijit/tests/form/test_Button.html
  2. Touch Edit button

Expected:

Menu opens and is usable when touched

Actual:

Menu opens when button is touched, disappears on touch release

Running Mobile Safari 5.1 on the latest version of iOS 5.1. May affect other menu widgets as well.

Change History (4)

comment:1 Changed 7 years ago by Colin Snover

Cc: bill added

comment:2 Changed 7 years ago by bill

Cc: bill removed
Component: Dijit - FormDijit
Owner: changed from Douglas Hays to bill
Status: newassigned
Summary: dijit/tests/form/test_Button.html drop-down menus fail in Mobile Safaridrop-down menus fail in Mobile Safari

I'll take this (at least initially). Menu is also failing so the problem isn't limited to dijit-form.

Last edited 7 years ago by bill (previous) (diff)

comment:3 Changed 7 years ago by bill

Problem started at [28275].

comment:4 Changed 7 years ago by bill

Resolution: fixed
Status: assignedclosed

In [28853]:

Don't fire synthetic click event until after all touchend listeners have finished running.

This fixes the problem where opening a DropDownButton's drop down on iOS would open then immediately close. _OnDijitClickMixin was firing the synthetic click event too early, which was flummoxing _HasDropDown because _onDropDownClick() was getting called before _onDropDownMouseUp().

Fixes #15501, refs #14918 !strict.

Note: See TracTickets for help on using tickets.