Opened 7 years ago

Closed 7 years ago

#15479 closed defect (duplicate)

'name' attribute on input does not work in ie7

Reported by: tanneman Owned by:
Priority: undecided Milestone: tbd
Component: HTML Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

When trying to set or get the name attribute of an input element this does not work on IE7. When using another element (eg div instead of input) it does work.

Steps to reproduce

  • use either way to create an input element
    • var inp = dojo.create('input', { name : 'test'});
    • var inp = dojo.create('input'); dojo.attr(inp, 'name', 'test');
  • Use dojo.attr(inp, 'name'); to get the input name.

Expected

  • The return value of dojo.attr(inp, 'name'); is 'test'

Actual

  • The return value is undefined.

Change History (1)

comment:1 Changed 7 years ago by bill

Component: GeneralHTML
Resolution: duplicate
Status: newclosed

Duplicate of #11812.
Right, this is a limitation of IE that you can't set the name of an input after it's created. The workaround is to use dojo.place() / toDom() to create the input.

Note: See TracTickets for help on using tickets.