Opened 7 years ago

Closed 7 years ago

Last modified 5 years ago

#15466 closed defect (fixed)

[patch][ccla]dijit.form.Select WAI-ARIA role should be listbox not combobox

Reported by: mikeb Owned by: mikeb
Priority: undecided Milestone: 1.8
Component: Accessibility Version: 1.7.2
Keywords: Cc: Douglas Hays, cjolif
Blocked By: Blocking:

Description

The dijit.form.Select has role=combobox but is more suited to a role=listbox since it generally doesn't accept user input and only provides a list of options.

Attachments (1)

a11ySelectAsRoleListbox.patch (15.2 KB) - added by mikeb 7 years ago.
fixes the drop downs with two nodes with role=listbox

Download all attachments as: .zip

Change History (10)

comment:1 Changed 7 years ago by mikeb

Component: Dijit - FormAccessibility
Milestone: tbd1.8
Owner: changed from Douglas Hays to mikeb

comment:2 Changed 7 years ago by mikeb

Cc: Douglas Hays added

comment:3 Changed 7 years ago by mikeb

Cc: cjolif added

comment:4 Changed 7 years ago by bill

Doug, I assume you'll check this in?

comment:5 Changed 7 years ago by Douglas Hays

After applying this patch, SelectMenu? now has 2 nodes with role=listbox

Changed 7 years ago by mikeb

fixes the drop downs with two nodes with role=listbox

comment:6 Changed 7 years ago by mikeb

Thanks Doug for catching that, I updated the patch.

comment:7 Changed 7 years ago by mikeb

In the patch, please dont remove this line: n.setAttribute("role", "presentation"); from form/Select.js (_selectMenu) It was accidentally removed when I created the patch. Thanks Doug

Last edited 7 years ago by mikeb (previous) (diff)

comment:8 Changed 7 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

In [29278]:

Fixes #15466. Change role=combobox to listbox instead, with menu items having role=option, and added automated tests.

comment:9 Changed 5 years ago by bill

#17737 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.