Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#15439 closed defect (duplicate)

[LESS][NODEJS] Error compiling a custom Claro theme

Reported by: Elia Contini Owned by: Rawld Gill
Priority: undecided Milestone: tbd
Component: Dijit - LnF Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

If I try to compile the variable.less file the result is

$ node compile.js 
The "sys" module is now called "util". It should have a similar interface.

Error: require.paths is removed. Use node_modules folders, or the NODE_PATH environment variable instead.
    at Function.<anonymous> (module.js:383:11)
    at Object.<anonymous> (/Users/elia/workspace/dojo/172-src/util/less/index.js:5:8)
    at Module._compile (module.js:446:26)
    at Object..js (module.js:464:10)
    at Module.load (module.js:353:31)
    at Function._load (module.js:311:12)
    at Module.require (module.js:359:17)
    at require (module.js:375:17)
    at Object.<anonymous> (/Users/elia/workspace/dojo/172-src/dijit/themes/claro/compile.js:8:9)
    at Module._compile (module.js:446:26)

System info:

  • Mac OS 10.7.4
  • nodejs 0.6.18

Change History (7)

comment:2 Changed 8 years ago by ben hockey

Component: BuildSystemDijit - LnF

this is a simple fix... we just need to update our copy of less in the repository. alternatively, it will work as is with node 0.4.x

comment:3 Changed 8 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #13501.

comment:4 Changed 8 years ago by ben hockey

i guess we already updated our copy of less :)

comment:5 Changed 8 years ago by bill

Yah, I'm assuming the reporter didn't set the version correctly. This is fixed in 1.7.

comment:6 Changed 8 years ago by ben hockey

the version is right... you can tell from the stack trace and you can see here that it's not fixed in 1.7 http://bugs.dojotoolkit.org/browser/dojo/tags/release-1.7.2/util/less/index.js#L5

comment:7 Changed 8 years ago by bill

OK, my mistake, there was also [27466] updating the version of less. So actually, it was fixed in 1.8, not 1.7. I'll update #13501.

Note: See TracTickets for help on using tickets.