Opened 7 years ago

Closed 5 years ago

#15421 closed enhancement (fixed)

[patch][cla] Chart : consistent SelectableLengend

Reported by: Mathevet julien Owned by: cjolif
Priority: high Milestone: 1.10
Component: Charting Version: 1.7.2
Keywords: 1.9 Cc:
Blocked By: Blocking:

Description

This patch fixe somes bug for selectable legends. SelectableLegend now works with all chart. It also use a fakeHighlight to avoid to connect event to chart.

But main raison I have done this patch it's to remove "bug" about filling shape in blank which it's really strange for stacked*, bubble and Pie. I hope for this reason this patch will be review to be include in 1.8.

I also get shape dynamically, which fix some bugs

I also add possibility to hide series/data at startup.

Attachments (1)

patchConsistentSelectableLegend.diff (39.6 KB) - added by Mathevet julien 7 years ago.

Download all attachments as: .zip

Change History (17)

comment:1 Changed 7 years ago by Mathevet julien

Another things:

  • clustered could be easier to read if you hide other. Size (width) is recompute.
  • For stacked* may be you need to set autoScale to true to redraw axis.

Pie hiding part need to be review.

Changed 7 years ago by Mathevet julien

comment:3 Changed 7 years ago by Eugene Lazutkin

Cc: cjolif added

comment:4 Changed 7 years ago by cjolif

Milestone: tbd1.9
Owner: changed from Eugene Lazutkin to cjolif
Status: newassigned

This definitely makes sense. The patch might need adaption. We will investigate that for the next release.

comment:5 Changed 7 years ago by Colin Snover

Milestone: 1.92.0

Current plan is that we are going from 1.8 to 2.0, so bulk reassigning and removing the 1.9 milestone so nobody tries to use it.

comment:6 Changed 7 years ago by Colin Snover

Keywords: 1.9 added

comment:7 Changed 7 years ago by cjolif

Type: defectenhancement

comment:8 Changed 5 years ago by cjolif

hi moogle, would you have time to adapt your patch to the current code base for inclusion in 1.10 (and 2.0)?

comment:9 Changed 5 years ago by cjolif

#17570 is a duplicate of this ticket.

comment:10 Changed 5 years ago by cjolif

Priority: undecidedhigh

comment:11 Changed 5 years ago by Mathevet julien

Hi, it's a long time.... Ok I will look.

Does Dojotoolkit accept Pull request ?

comment:12 Changed 5 years ago by cjolif

yes. You need to link this ticket from your pull request.

See: https://github.com/dojo/dojox/pulls

comment:14 Changed 5 years ago by cjolif

ok thanks a lot. I started looking into this but I won't have much time this week, so hopefully I'll do a deeper review next week.

comment:15 Changed 5 years ago by cjolif

Cc: cjolif removed
Milestone: 2.01.10

comment:16 Changed 5 years ago by Christophe Jolif <cjolif@…>

Resolution: fixed
Status: assignedclosed

In f58636bb1f58c7327a39d6260f7279fd1feb1955/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.