Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#15404 closed defect (fixed)

[regression] Mouse button in quirks mode (Tree selection)

Reported by: doda Owned by: Kris Zyp
Priority: blocker Milestone: 1.7.4
Component: Events Version: 1.7.0
Keywords: Cc:
Blocked By: Blocking:

Description

Tree will not receive any selection changes when displayed in Firefox in quirks mode:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

Cause:

dojo.mouse.isLeft(e)

does not return true if left clicked.

This is a general problem in dojo.mouse:

if(has("dom-quirks") || !has("dom-addeventlistener")){

Firefox (also Safari and Chrome) seem to use the normal mouse button values (0,1,2) in quirks mode.

Can be tested with the attached example

Attachments (1)

dojo_tree_selection.html (1.8 KB) - added by doda 8 years ago.
Test example

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by doda

Attachment: dojo_tree_selection.html added

Test example

comment:1 Changed 7 years ago by bill

Component: GeneralEvents
Owner: set to Kris Zyp

The obvious thing would be to add a has("ie") to the condition, not sure if there's a more politically correct way.

comment:2 Changed 7 years ago by cjong

Workarround in Chrome:

add "<!DOCTYPE HTML>" before <html> tag.

Dont ask me why. I think it forces quirk mode.

Chris

comment:3 Changed 7 years ago by Kenneth G. Franqueiro

Milestone: tbd1.7.4
Priority: undecidedhigh
Version: 1.7.21.7.0

I logged #16026 today which Bill pointed out was a duplicate of this. As such, since I've found this to be a regression as of 1.7, I'm updating the priority of this accordingly.

comment:4 Changed 7 years ago by Kenneth G. Franqueiro

Summary: Mouse button in quirks mode (Tree selection)[regression] Mouse button in quirks mode (Tree selection)

comment:5 Changed 7 years ago by Kenneth G. Franqueiro

#16026 is a duplicate of this ticket.

comment:6 Changed 7 years ago by Kitson Kelly

Priority: highblocker

Change to blocker as per weekly meeting.

comment:7 Changed 7 years ago by Kris Zyp

Resolution: fixed
Status: newclosed

In [29713]:

Fix feature detection for switching mouse click constants, fixes #15404 !strict

comment:8 Changed 7 years ago by Kris Zyp

In [29714]:

Fix feature detection for switching mouse click constants, fixes #15404 !strict

comment:9 Changed 7 years ago by Kris Zyp

In [29715]:

Fix feature detection for switching mouse click constants, fixes #15404 !strict

Note: See TracTickets for help on using tickets.