Opened 7 years ago

Last modified 2 years ago

#15388 reopened defect

Tooltip inside scrollable ContentPane does not scroll with node

Reported by: chrisdn Owned by:
Priority: undecided Milestone: 1.15
Component: Dijit Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

On a dijit, such as a ValidationTextBox? with required = true, the validation tool-tip does not scroll with said dijit when the dijit is inside a nested ContentPane?.

The behavior can be observed here: http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/themes/themeTester.html

  1. Select the Text Input Widgets tab
  2. Size your browser (I'm using Firefox latest) so that the tab's pane gets a vertical scrollbar.
  3. Clear-out the CurrencyTextBox? field and get the tool-tip to show.
  4. Scroll the pane. The tool-tip should be hovering where it initially opened.

Change History (6)

comment:1 Changed 7 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #5777.

comment:2 Changed 6 years ago by bill

Milestone: tbdfuture
Resolution: duplicate
Status: closedreopened

Actually, #5777 fixed issues with code that calls dijit/popup, but Tooltip just calls dijit/place.

comment:3 Changed 5 years ago by dbsalgad

Is there any movement on this defect? Please let us know the target for this.

Thanks! David

comment:4 Changed 5 years ago by yzuo

Hello,

Is there a target date for this defect to be resolved?

Thanks, Ying

comment:5 Changed 3 years ago by dylan

Milestone: future1.12

Realistically, unless someone creates a pull request for this, it's not going to get addressed any time soon. I'll mark it for consideration for 1.12, but if you would like to help create a fix, that would be great!

comment:6 Changed 2 years ago by dylan

Milestone: 1.131.15

Ticket planning... move current 1.13 tickets out to 1.15 to make it easier to move tickets into the 1.13 milestone.

Note: See TracTickets for help on using tickets.