Opened 7 years ago

Closed 7 years ago

#15361 closed defect (invalid)

StatefulModel breaks when bound to a CurrencyTextBox

Reported by: mikerobi Owned by: Ed Chatelain
Priority: undecided Milestone: tbd
Component: DojoX MVC Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

When a CurrencyTextBox? is bound to a StatefulModel?, the first call to the setter does not work.

In my attached example, calling the getter after setting the value for the first time returns undefined.

This is broken in 1.7.2 and a recent checkout.

Attachments (1)

currencyMvc.html (727 bytes) - added by mikerobi 7 years ago.
Example

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by mikerobi

Attachment: currencyMvc.html added

Example

comment:1 Changed 7 years ago by Ed Chatelain

Resolution: invalid
Status: newclosed

Very sorry for the long delay in dealing with this. But I believe the problem in the test is caused by setting x: null, in the model initially. null is not valid for the CurrencyTextbox?. If you set x: '0', you will see the first update works.

Note: See TracTickets for help on using tickets.