Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15349 closed defect (invalid)

dojo.date.stamp.fromISOString on Android Bug

Reported by: Pete Smith Owned by:
Priority: undecided Milestone: tbd
Component: General Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

var d = dojo.date.stamp.fromISOString("2012-05-16T21:00:00.000-04:00");

d on firefox (correct): Date {Wed May 16 2012 21:00:00 GMT-0400 (EDT)} d on android (incorrect): Date {Thur May 17 2012 01:00:00 GMT+0000 (GMT)

Might have something to do with the offset, which firefox does right, but android does wrong. Strangely, PM times work fine.

Change History (2)

comment:1 Changed 7 years ago by Adam Peller

Resolution: invalid
Status: newclosed

Looks like the result of Date.toString() on Android is just shown in GMT, but it's the same time. Not a bug.

comment:2 Changed 7 years ago by Pete Smith

Peller, you are absolutely right. After more investigation the phone's timezone was set to GMT. I was unaware that the date handling took that into account. Thank you for your quick answer.

Note: See TracTickets for help on using tickets.