Opened 8 years ago

Closed 8 years ago

#15341 closed defect (invalid)

"String contains an invalid character" code: "5" nsresult: "0x80530005 (NS_ERROR_DOM_INVALID_CHARACTER_ERR)" location: "

Reported by: BinaryBlock Owned by: BinaryBlock
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

I inherited a dojo project that was built on version: version 1.3.2 (18832)

We are trying to upgrade to dojo version 1.7.2

Here is exception output we a getting:

uncaught exception: [Exception... "String contains an invalid character"  code: "5" nsresult: "0x80530005 (NS_ERROR_DOM_INVALID_CHARACTER_ERR)"  location: "http://dev.domain.com:8081/backPage/dojoroot/dojo/dojo.js Line: 10525"]
http://dev.domain.com:8081/backPage/dwr/engine.js

Line 10525 (dojo.js.uncompressed.js) had:

node.setAttribute(attrNames[lc] || name, value);

Wrapped in try/catch and got following values causing problem:

Name: _dijitMenudijit_layout_TabContainer_0_tablist_tab_User_- John Doe_Menu Value: 1

output above came from JS alert I put in for testing:

alert("Name: "+name+" Value: "+value);

Added empty try/catch to stop JS error and allow application to continue... difficult, because I am using dojo.js (compressed) in Production and don't know what utility was used to compress JS.. so I did it manually:

{return prop.set(node,name,_38b);}try{node.setAttribute(_386[lc]
name,_38b)}catch(e){};return node;};

Is there another way to do this?

Change History (2)

comment:1 Changed 8 years ago by bill

Component: GeneralDijit
Owner: set to BinaryBlock
Status: newpending

Please attach a test case using the "attach file" button. It should be as small as possible to still reproduce the problem, almost always a single HTML file that we can load in the browser and use to reproduce then problem.

Then, give exact instructions on how to reproduce the problem using your attached test file.

The test case is necessary both to confirm that there's a bug, and for us to be able to debug the problem.

Also, to debug on your end, you should stop using the compressed dojo, and use the uncompressed one instead,

comment:2 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.