Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15337 closed defect (wontfix)

[editor.linkdialog]cannot follow created link

Reported by: gerhard presser Owned by:
Priority: low Milestone: tbd
Component: Editor Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

I cannot click the link in IE (8/9) it works fine in FF

can be reproduced at:

http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/editor/test_LinkDialog.html

single-click(+ctrl) doesn't open the link, but double-click opens the link-details

Change History (5)

comment:1 Changed 7 years ago by bill

Priority: undecidedlow
Resolution: wontfix
Status: newclosed

Hmm, I think this is just a difference between browsers. What makes you think that FF is the "correct behavior"? I don't see why a user would want to click a link in a document they were editing, since that would navigate to a different page and lose all their edits.

comment:2 Changed 7 years ago by gerhard presser

so what's the purpose of the link-pane - just to add a link nobody can click out of the box. Do I have to display the content in a proper way myself to make it clickable?

the purpose of adding a image in a document is to view it, and the purpose of adding a link is to click it - or am I wrong?

regards

comment:3 Changed 7 years ago by bill

I thought you would display the content outside of the editor, in the same way that this bug database has separate areas for editing text and displaying it. (Another analogy is that in this bug database you can only click a link after you've finished editing and saved.)

comment:4 in reply to:  3 Changed 7 years ago by gerhard presser

but the editor displays the link as link after I inserted it - the bug-db displays the actual link only in the 'readonly'-area.

if something looks like a link, I think it's eligible if somebody wants to click it!?

Replying to bill:

I thought you would display the content outside of the editor, in the same way that this bug database has separate areas for editing text and displaying it. (Another analogy is that in this bug database you can only click a link after you've finished editing and saved.)

comment:5 Changed 7 years ago by bill

Well, that's one way of looking at it, although dojo's behavior is not unusual: compare with http://ckeditor.com/demo. Those links cannot be navigated to either. Google docs pops up a nice tooltip giving the user a choice, but anyway merely clicking a link won't automatically navigate to a different page.

Note: See TracTickets for help on using tickets.