Opened 8 years ago

Closed 8 years ago

#15335 closed defect (duplicate)

eclipse show error : Duplicate case

Reported by: jzw Owned by:
Priority: undecided Milestone: tbd
Component: General Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

in file: dojox/xmpp/xmppSession.js

switch(n.nodeName){
	case 'status': //1
	case 'show':
	        p[n.nodeName]=n.firstChild.nodeValue;
		break;
        case 'status': //2                                    
                p.priority=parseInt(n.firstChild.nodeValue);break;
	case 'x':
	    if(n.firstChild && n.firstChild.firstChild&&
n.firstChild.firstChild.nodeValue != "") {
                 p.avatarHash= n.firstChild.firstChild.nodeValue;
                 p.hasAvatar = true;
	}
	break;
}

two case 'status'

Change History (1)

comment:1 Changed 8 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #14588.

Note: See TracTickets for help on using tickets.