Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15333 closed defect (invalid)

Wrong bottom align of ScrollableView within SwapView and View

Reported by: youngho Owned by: youngho
Priority: undecided Milestone: tbd
Component: DojoX Mobile Version: 1.7.2
Keywords: Cc: Eric Durocher
Blocked By: Blocking:

Description

Hello,

A dojox.mobile.ScrollableView? within a dojox.mobile.SwapView? and dojox.mobile.View with top, bottom Heading shows wrong bottom align when scrolling bottom to up

Attachments (1)

test_ScrollableView-hv-ah-af_1.html (10.4 KB) - added by youngho 7 years ago.

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by youngho

comment:1 Changed 7 years ago by ykami

Cc: Eric Durocher added
Owner: changed from ykami to youngho
Status: newpending

Seems to be failing to find the application-level header/footer bars. You should remove the top level View node for the bars to be top level.

comment:2 Changed 7 years ago by youngho

Status: pendingnew

How can we guarantee an user doesn't use such combination within a View ? Typically I use such combination within a view for multiscreen switch transition.

comment:3 Changed 7 years ago by ykami

Status: newpending

Which type of fixed bar are you trying to create, application-level (always stays regardless of view transitions) or view-local (moves with the view when view transition is performed)?

comment:4 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:5 Changed 7 years ago by Prutkar

Dojo 1.8.1

Following setup does not present bottom fixed header (or TabBar?) correctly, ScrollableView? takes over whole screen not adjusting itself for the bottom fixed positioned element.

View

SwapView?

Heading fixed: "top"

ScrollableView?

Heading fixed: "bottom" (or TabBar?, fixed: "bottom")

SwapView?

Heading fixed: "top"

ScrollableView?

Heading fixed: "bottom" (or TabBar?, fixed: "bottom")

Last edited 7 years ago by Prutkar (previous) (diff)

comment:6 in reply to:  5 Changed 7 years ago by ykami

I tried your setup with dojo-1.8 (by modifying your attachment), but was not able to reproduce the problem. Seems to be working fine. Can you provide a small example code?

Note: See TracTickets for help on using tickets.