Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#15312 closed defect (fixed)

Error when require dojox.grid.EnhancedGrid.plugins.Filter with CDN

Reported by: Jovanovic Owned by: Evan
Priority: high Milestone: 1.7.4
Component: DojoX Grid Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

Hello,

When require dojox.grid.EnhancedGrid?.plugins.Filter with a CDN, error 404 appear :

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE)" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: http://ajax.googleapis.com/ajax/libs/dojo/1.7.2/dojo/dojo.js :: <TOP_LEVEL> :: line 15" data: no]

Error: Unable to load null status:404

and when html templates are loaded :

405 Method Not Allowed

test code :

<script>
	dojoConfig= {
		has: {
			"dojo-firebug": true
		},
		parseOnLoad: true,
		isDebug: true,
		async:true
	};
</script>

<script src="http://ajax.googleapis.com/ajax/libs/dojo/1.7.2/dojo/dojo.js" data-dojo-config="parseOnLoad: true"></script>

<script>
require(["dojox/grid/EnhancedGrid","dojox/grid/enhanced/plugins/Filter"]);
</script>

Attachments (3)

Filter.patch (1.6 KB) - added by Adam Peller 8 years ago.
remove old dojo.i18n references
grid.html (362 bytes) - added by bill 7 years ago.
test against 1.8 release
15312.patch (6.0 KB) - added by Evan 7 years ago.
Patch to be applied to 1.7.x + 1.8.x after 1.8 GA

Download all attachments as: .zip

Change History (14)

comment:1 Changed 8 years ago by Adam Peller

Milestone: tbd1.8
Priority: undecidedhigh

Unrelated, but I'd also consider removing the try/catch in Filter's destroy() method

Changed 8 years ago by Adam Peller

Attachment: Filter.patch added

remove old dojo.i18n references

comment:2 Changed 7 years ago by Evan

In [28779]:

Refs #15312, remove old dojo.i18n API

comment:3 Changed 7 years ago by Evan

In [28780]:

Refs #15312 !strict, remove old dojo.i18n API

comment:4 Changed 7 years ago by Evan

Not sure if [28779]/[28781] has fixed this issue, may need a CDN test before closing this ticket.

Last edited 7 years ago by Evan (previous) (diff)

comment:5 Changed 7 years ago by Evan

In [28781]:

Refs #15312 !strict, remove old dojo.i18n API - a shorter parameter name

comment:6 Changed 7 years ago by Colin Snover

Milestone: 1.82.0

1.8 has been tagged; moving all outstanding tickets to next major release milestone.

comment:7 Changed 7 years ago by bill

I thought this might have been fixed, but I tried against the 1.8 release (see attachment) and it still gets errors about loading the templates, as though the build tool didn't inline them for some reason, probably you aren't using dojo/text! to load them?

Either that, or I was running against a src tree where templates weren't inlined.

Last edited 7 years ago by bill (previous) (diff)

Changed 7 years ago by bill

Attachment: grid.html added

test against 1.8 release

comment:8 in reply to:  7 Changed 7 years ago by Evan

Milestone: 2.01.8.1

Replying to bill:

I thought this might have been fixed, but I tried against the 1.8 release (see attachment) and it still gets errors about loading the templates, as though the build tool didn't inline them for some reason, probably you aren't using dojo/text! to load them?

Either that, or I was running against a src tree where templates weren't inlined.

The issue still exists in CDN, templates needs to be inlined in src build as well, caused by several places missed being updated to dojo.text!

Changed 7 years ago by Evan

Attachment: 15312.patch added

Patch to be applied to 1.7.x + 1.8.x after 1.8 GA

comment:9 Changed 7 years ago by Evan

Resolution: fixed
Status: newclosed

In [29497]:

Fixes #15312 !strict, use dojo/text! so that templates will all be inlined in CDN build

comment:10 Changed 7 years ago by Evan

In [29498]:

Refs #15312 !strict, backport to 1.8.x, 1.7.x branch

comment:11 Changed 7 years ago by Evan

Milestone: 1.8.11.7.4
Note: See TracTickets for help on using tickets.