Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#15307 closed defect (duplicate)

dojo/require! doesn't execute after 2 dependencies

Reported by: Ed Siok Owned by: Rawld Gill
Priority: undecided Milestone: 1.8
Component: Loader Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

Found this after the dojo build process tried converting all of my files to use the AMD spec with the dojo/require! plugin. At no point would any of my required's execute, but it appeared as though it was actually downloading all of the files.

After a couple days of working on this, I found that after 2 levels of using dojo/require!, to download and execute modules, it stopped executing the modules. So for example:

rootdojo.require(module1) -- module1 (dojo/require!module2)



module 3 will not be executed, but module1 and module2 _will_ be executed.

This makes upgrades from previous versions of dojo completely impossible without converting _everything_ to using the AMD spec (which is not what I was hoping to do today)

Please see the attached test which can be placed in the 1.7/dojo/tests/_base/loader. From there you can see that module1 and module2 are executing, but that module3 never gets executed.

Attachments (1)

require.tar.gz (1.3 KB) - added by Ed Siok 8 years ago.
A test case that proves the failure

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by Ed Siok

Attachment: require.tar.gz added

A test case that proves the failure

comment:1 Changed 8 years ago by Ed Siok

Sorry, my formating got screwed up there. Let's try something else:

root - (dojo.require(module1))
.. module1 (dojo/require!module2)
.... module2 (dojo/require!module3)
...... module3 - Never gets executed

comment:2 Changed 8 years ago by Ed Siok

Please hold on this- I just realized that I was never calling dojo.require("module3") in module2. I am still trying to recreate the exact scenario where I'm seeing this problem.

comment:3 Changed 8 years ago by Ed Siok

Just noticed this is only happening on the stable version of 1.7.2; looks like it's fixed on the trunk version. Any idea when 1.7.3 will be released?

comment:4 Changed 8 years ago by Rawld Gill

Milestone: tbd1.8
Resolution: duplicate
Status: newclosed

Hi sioked, thanks for the report!

This has been fixed in trunk and will be backported to 1.7.3. Please reopen if you find that trunk not working as expected.

comment:5 Changed 8 years ago by Colin Snover

Duplicate of what?

Note: See TracTickets for help on using tickets.